aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-27 11:30:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-27 12:31:55 +0100
commit9958653b2bf9e43312a39c6b89ff0ca1cc46995c (patch)
treecb6dcc97b75937ae8c45189cfc78aa0440ea53a2 /meta
parent8792f38de43b391896c2eccb8086538eb3f6c47b (diff)
downloadopenembedded-core-9958653b2bf9e43312a39c6b89ff0ca1cc46995c.tar.gz
perf: Ensure we general PIC code to avoid build failures
Without this we see relocation errors on mips with 3.10. This should be safe to be included in general. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 844e8807ca..a78fc057bb 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -73,7 +73,7 @@ EXTRA_OEMAKE = \
# don't override it, it'll add -m32/-m64 itself). For LDFLAGS, it was failing
# to find bfd symbols.
EXTRA_OEMAKE += "\
- 'CFLAGS=${CFLAGS}' \
+ 'CFLAGS=${CFLAGS} -fPIC' \
'LDFLAGS=${LDFLAGS} -lpthread -lrt -lelf -lm -lbfd' \
\
'prefix=${prefix}' \