aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2013-09-10 17:24:14 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-10 23:00:33 +0100
commit637e0484ea4e7a39ac4d9c407c585201e6be1bc0 (patch)
tree4cb765f8e3e3fdd0cd98a1a93530f4ba9a3fc0be /meta
parent2df21a3b27543df912a3ce05bef2415fae13cb7c (diff)
downloadopenembedded-core-637e0484ea4e7a39ac4d9c407c585201e6be1bc0.tar.gz
btrfs-tools: fix a parallel build issue
Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools/btrfs-progs-fix-parallel-build.patch30
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools/btrfs-progs-fix-parallel-build.patch b/meta/recipes-devtools/btrfs-tools/btrfs-tools/btrfs-progs-fix-parallel-build.patch
new file mode 100644
index 0000000000..e461cdf447
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools/btrfs-progs-fix-parallel-build.patch
@@ -0,0 +1,30 @@
+btrfs-progs: fix parallel build
+
+Upstream-Status: Submitted [http://permalink.gmane.org/gmane.comp.file-systems.btrfs/28197]
+
+Parallel execution of "make install" may fail due to late creation of
+version.h, fix it by adding the dependence on version.h.
+
+The fix is similare to 7aaf00fc[btrfs-progs: fix parallel build]
+
+Signed-off-by: Roy.Li <rongqing.li@windriver.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index c43cb68..40ef205 100644
+--- a/Makefile
++++ b/Makefile
+@@ -190,7 +190,7 @@ clean :
+ $(libs) $(lib_links)
+ $(Q)$(MAKE) $(MAKEOPTS) -C man $@
+
+-install: $(libs) $(progs) install-man
++install: version.h $(libs) $(progs) install-man
+ $(INSTALL) -m755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) $(progs) $(DESTDIR)$(bindir)
+ $(INSTALL) -m755 -d $(DESTDIR)$(libdir)
+--
+1.7.10.4
+
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb
index 1c7f34f8d7..fe6a35a274 100644
--- a/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_git.bb
@@ -20,6 +20,7 @@ S = "${WORKDIR}/git"
PV = "0.20+git${SRCPV}"
SRC_URI += "file://weak-defaults.patch"
+SRC_URI += "file://btrfs-progs-fix-parallel-build.patch"
do_install () {
oe_runmake 'DESTDIR=${D}' install