aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-09-04 22:20:22 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-05 16:27:07 +0100
commit5799df791043bd77c0f31e6068ab99e21d6ad25e (patch)
treee66816571832f5506b55fb9d97d33f2e863814c5 /meta
parent22c0668d9e0a22c095d78bab7b45ef4f803dd0d1 (diff)
downloadopenembedded-core-5799df791043bd77c0f31e6068ab99e21d6ad25e.tar.gz
linux-yocto/3.10: fix YAFFS2 build issues
The 3.10 yaffs2 refresh caused several build errors. One due the single kernel version support being incomplete, and two others due to core kernel changes creating incompatbilies with the yaffs2 code. The following three commits fix the issues. b76f445 yaffs2: disable procfs support ecfe5ed yaffs2: convert to kuid_t and kgid_t fa8efc9 yaffs2: restore multi-kernel version functionality bumping the SRCREVs for all BSPs to import the fix. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.10.bb14
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
index cfcb71141b..797cad7ce3 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
@@ -3,8 +3,8 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH = "standard/preempt-rt/base"
KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
-SRCREV_machine ?= "8a9b4902683f586f7d656c2e6747e314a5e1ed0e"
-SRCREV_machine_qemuppc ?= "655d20d4f64dc053b40ac8d8fe44b82dec5e130a"
+SRCREV_machine ?= "94e63f0640ef3680a605e82ee19f3de688f0ec59"
+SRCREV_machine_qemuppc ?= "2c0455935f1964ce69c70d0f7980a656040e50ea"
SRCREV_meta ?= "cd502a88148ab214b54860f97a96f41858fd6446"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
index 5b8462062c..2d855375ce 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "3.10.9"
KMETA = "meta"
-SRCREV_machine ?= "7144bcc4b8091675bfcf1941479067857b6242da"
+SRCREV_machine ?= "b76f4452b72080a538406abc9b290a5d811d61f8"
SRCREV_meta ?= "cd502a88148ab214b54860f97a96f41858fd6446"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.10.bb b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
index 71218812be..b6d9eaecbb 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
@@ -3,13 +3,13 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH_DEFAULT = "standard/base"
KBRANCH = "${KBRANCH_DEFAULT}"
-SRCREV_machine_qemuarm ?= "24d53cd6ca4c3ae8f5dd2ff840f9275327d955ee"
-SRCREV_machine_qemumips ?= "0480771238bb87031b79ecb1ee6bce7bfe6ffb1c"
-SRCREV_machine_qemuppc ?= "a9c383957f69e70fd2cb27d885160303a305cf57"
-SRCREV_machine_qemux86 ?= "7144bcc4b8091675bfcf1941479067857b6242da"
-SRCREV_machine_qemux86-64 ?= "7144bcc4b8091675bfcf1941479067857b6242da"
-SRCREV_machine_qemumips64 ?= "10a8db0603d7186633a6bf90e2308710763e718e"
-SRCREV_machine ?= "7144bcc4b8091675bfcf1941479067857b6242da"
+SRCREV_machine_qemuarm ?= "d8c48090a1272c69e009c4ef5fa675fc8db178cc"
+SRCREV_machine_qemumips ?= "181188440e96896fbc69fa2c5ea5d2ee43304da0"
+SRCREV_machine_qemuppc ?= "c0a23bc4b4d6be3d2f09a81dfeb3456f51b8d439"
+SRCREV_machine_qemux86 ?= "b76f4452b72080a538406abc9b290a5d811d61f8"
+SRCREV_machine_qemux86-64 ?= "b76f4452b72080a538406abc9b290a5d811d61f8"
+SRCREV_machine_qemumips64 ?= "3a0d015e9908b69666c7f7780502aed4d115de1d"
+SRCREV_machine ?= "b76f4452b72080a538406abc9b290a5d811d61f8"
SRCREV_meta ?= "cd502a88148ab214b54860f97a96f41858fd6446"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"