aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-12-20 15:15:40 +0200
committerSaul Wold <sgw@linux.intel.com>2013-01-09 16:40:38 -0800
commit2e6c202c000cfd0edbc024468c9f6c4b8b7eb816 (patch)
treedb9a9be7fe058654f3ea7623c1fd9afeaa679fe2 /meta
parent78281edfe2342dccd7f598277464a3dd05ac4c0e (diff)
downloadopenembedded-core-2e6c202c000cfd0edbc024468c9f6c4b8b7eb816.tar.gz
matchbox-keyboard: use the gtk-immodules-cache.bbclass
Since the class was already present, use it. Also, this will have the postinstalls run on host, at do_rootfs time. [YOCTO #3602] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb18
1 files changed, 2 insertions, 16 deletions
diff --git a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
index adde25bcf0..a7091d2519 100644
--- a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
+++ b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
@@ -22,7 +22,7 @@ SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
S = "${WORKDIR}/git"
-inherit autotools pkgconfig gettext
+inherit autotools pkgconfig gettext gtk-immodules-cache
EXTRA_OECONF = "--disable-cairo --enable-gtk-im --enable-applet"
@@ -49,18 +49,4 @@ do_install_append () {
rm -f ${D}${libdir}/matchbox-panel/*.la
}
-pkg_postinst_matchbox-keyboard-im () {
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-
-gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
-}
-
-pkg_postrm_matchbox-keyboard-im () {
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-
-gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
-}
+GTKIMMODULES_PACKAGES = "${PN}-im"