aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTomas Frydrych <tomas@sleepfive.com>2013-05-10 14:36:39 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-12 08:35:16 +0100
commit271b772855e091f5d0d97594acd613a9aee47fcb (patch)
tree87a2c57ab14b4b8e2218c10be8ac380441457801 /meta
parent68d7300e2cc55a5b873345874243da589e04bba0 (diff)
downloadopenembedded-core-271b772855e091f5d0d97594acd613a9aee47fcb.tar.gz
librsvg: update gdk-pixbuf loader cache when staging native package
librsvg installs an svg loader for gdk-pixbuf; in order for the native version of the loader to be usable by gdk-pixbuf-native we have to update the loader cache. Signed-off-by: Tomas Frydrych <tomas@sleepfive.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.32.1.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb b/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb
index ff17cf75ed..dcacce4b00 100644
--- a/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb
+++ b/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb
@@ -55,3 +55,14 @@ FILES_librsvg-gtk-dbg += "${libdir}/gdk-pixbuf-2.0/.debug \
PIXBUF_PACKAGES = "librsvg-gtk"
PARALLEL_MAKE = ""
+
+# ensure that the native gdk-pixbuf loaders cache is updated when we stage
+# our svg loader
+SSTATEPOSTINSTFUNCS_class_native += "librsvg_sstate_postinst"
+
+librsvg_sstate_postinst() {
+ if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
+ then
+ GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/2.10.0/loaders GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/2.10.0/loaders.cache gdk-pixbuf-query-loaders --update-cache
+ fi
+}