summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-19 15:18:16 -0800
committerSteve Sakoman <steve@sakoman.com>2023-01-31 13:15:53 -1000
commitf7c2e4c768bb6870992a86bc500d960d4c88f929 (patch)
treefb31888de665b3b497f07c5e51bdb943e21ba983 /meta
parentda48bc443fec5bbc1fce356c3d5fd551a38a0705 (diff)
downloadopenembedded-core-f7c2e4c768bb6870992a86bc500d960d4c88f929.tar.gz
libtirpc: Check if file exists before operating on it
In some cases (e.g. mingw) this file may not be installed Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 547f3a13ee9268bbdd439c96108ba1fe9ab78873) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb b/meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb
index 8c6c20733c..f55e0b0ed1 100644
--- a/meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb
+++ b/meta/recipes-extended/libtirpc/libtirpc_1.3.3.bb
@@ -22,7 +22,7 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--disable-gssapi"
do_install:append() {
- chown root:root ${D}${sysconfdir}/netconfig
+ test -e ${D}${sysconfdir}/netconfig && chown root:root ${D}${sysconfdir}/netconfig
}
BBCLASSEXTEND = "native nativesdk"