aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2015-04-30 16:51:13 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-28 09:41:52 +0100
commit24a98efa442b323667e1471886ad874e607ff320 (patch)
tree6c708194bc260bb935997fed13efa98ad5b440e8 /meta/recipes-support
parent5eda84a62201461b9c69498ec35585d2c8142dec (diff)
downloadopenembedded-core-24a98efa442b323667e1471886ad874e607ff320.tar.gz
libcap: Avoid passing "-e" to make
oe-core 51540b64f62234c145fc32cfa3fbbaaebbeece08 altered libcap.inc (at the time) to append to EXTRA_OEMAKE rather than assign to it. The default value for EXTRA_OEMAKE contains "-e". This means that the change caused "-e" to be passed to make for the first time. Unfortunately passing "-e" subtly changes the behaviour of libcap's Make.Rules under recursive make when prefix="" (which it is for us since we're using meta-micro.) Without "-e" the prefix comes from the command line in both the parent and submakes. This takes precedence over any attempt to reassign it with a simple "=" operation so the headers are correctly installed in (empty string)/include. With "-e" the prefix still comes from the command line in the parent make but from the environment in the submake. The attempt to assign it fails in the parent make as before, but not in the submake so the headers are installed incorrectly in /usr/include. In all four cases the "ifdef prefix" else clause is executed. So, let's assign EXTRA_OEMAKE in order to avoid using "-e" at all. (From OE-Core rev: a8d35fa4fd76ea4a70063492cd5eab0858f2edb6) Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libcap/libcap_2.24.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/libcap/libcap_2.24.bb b/meta/recipes-support/libcap/libcap_2.24.bb
index 75cf5d415d..f50dc941fe 100644
--- a/meta/recipes-support/libcap/libcap_2.24.bb
+++ b/meta/recipes-support/libcap/libcap_2.24.bb
@@ -32,7 +32,7 @@ PACKAGECONFIG_class-native ??= ""
PACKAGECONFIG[attr] = "LIBATTR=yes,LIBATTR=no,attr"
PACKAGECONFIG[pam] = "PAM_CAP=yes,PAM_CAP=no,libpam"
-EXTRA_OEMAKE += " \
+EXTRA_OEMAKE = " \
INDENT= \
lib=${@os.path.basename('${libdir}')} \
RAISE_SETFCAP=no \