aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-06-07 05:00:00 -0700
committerScott Garman <scott.a.garman@intel.com>2012-07-18 10:20:36 -0700
commit9f7e9fb6cd08b3048e97dd1011f0510416beb103 (patch)
tree2989750372d06a0f513cccdeb5310dea3b35051e /meta/recipes-support
parent1d55679821003ac4d652b08f2eebab1636505042 (diff)
downloadopenembedded-core-9f7e9fb6cd08b3048e97dd1011f0510416beb103.tar.gz
curl: enable ssl support
This patch enables ssl support for curl to allow git to clone from https / ssl sites. We do not want to enable gnutls for native or nativesdk, as it adds additional dependency and increase build time [YOCTO #2532] Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/curl/curl_7.24.0.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-support/curl/curl_7.24.0.bb b/meta/recipes-support/curl/curl_7.24.0.bb
index 12e95c9bc0..f9dce7de12 100644
--- a/meta/recipes-support/curl/curl_7.24.0.bb
+++ b/meta/recipes-support/curl/curl_7.24.0.bb
@@ -5,10 +5,10 @@ SECTION = "console/network"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
-DEPENDS = "zlib gnutls"
-DEPENDS_virtclass-native = "zlib-native"
-DEPENDS_virtclass-nativesdk = "zlib-nativesdk"
-PR = "r0"
+DEPENDS = "zlib gnutls openssl"
+DEPENDS_virtclass-native = "zlib-native openssl-native"
+DEPENDS_virtclass-nativesdk = "zlib-nativesdk openssl-nativesdk"
+PR = "r1"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://noldlibpath.patch \
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "ebdb111088ff8b0e05b1d1b075e9f1608285e8105cc51e21caacf33d01
inherit autotools pkgconfig binconfig
EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
- --without-ssl \
+ --with-ssl \
--without-libssh2 \
--with-random=/dev/urandom \
--without-libidn \