aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2013-03-15 16:04:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-16 17:14:09 +0000
commitd2e7d98ce859a3af037135d1ac7bdb7a34f4d319 (patch)
tree17ed4763eca458c8a971bdcf40efd55b31766d21 /meta/recipes-support
parent7720c356534e46614578619d5a8f0462485b81f6 (diff)
downloadopenembedded-core-d2e7d98ce859a3af037135d1ac7bdb7a34f4d319.tar.gz
gnupg: fix PN -> BPN in do_install for multilibs
Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/gnupg/gnupg_1.4.7.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_1.4.7.bb b/meta/recipes-support/gnupg/gnupg_1.4.7.bb
index 8c2f7f625f..7fbc3d39ff 100644
--- a/meta/recipes-support/gnupg/gnupg_1.4.7.bb
+++ b/meta/recipes-support/gnupg/gnupg_1.4.7.bb
@@ -7,7 +7,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
-PR = "r8"
+PR = "r9"
SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-${PV}.tar.bz2 \
file://long-long-thumb.patch \
@@ -79,9 +79,9 @@ EXTRA_OECONF = "--disable-ldap \
do_install () {
autotools_do_install
- install -d ${D}${docdir}/${PN}
- mv ${D}${datadir}/${PN}/* ${D}/${docdir}/${PN}/ || :
- mv ${D}${prefix}/doc/* ${D}/${docdir}/${PN}/ || :
+ install -d ${D}${docdir}/${BPN}
+ mv ${D}${datadir}/${BPN}/* ${D}/${docdir}/${BPN}/ || :
+ mv ${D}${prefix}/doc/* ${D}/${docdir}/${BPN}/ || :
}
# split out gpgv from main package
@@ -90,5 +90,5 @@ PACKAGES =+ "gpgv"
FILES_gpgv = "${bindir}/gpgv"
# Exclude debug files from the main packages
-FILES_${PN} = "${bindir}/* ${datadir}/${PN} ${libexecdir}/${PN}/*"
-FILES_${PN}-dbg += "${libexecdir}/${PN}/.debug"
+FILES_${PN} = "${bindir}/* ${datadir}/${BPN} ${libexecdir}/${BPN}/*"
+FILES_${PN}-dbg += "${libexecdir}/${BPN}/.debug"