aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorSong.Li <Song.Li@windriver.com>2012-06-29 09:29:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-30 20:55:24 +0100
commitb8bf6cc43dd08fcc7394053b31f03d5312ed239c (patch)
tree5b1a154d7d3d8af3b38196de1d2368b6270b5e85 /meta/recipes-support
parent7dd4d0178e2b057f76cd2b0b6fe8402f8c1ab23d (diff)
downloadopenembedded-core-b8bf6cc43dd08fcc7394053b31f03d5312ed239c.tar.gz
libnl: fix two parentheses bugs in lib/cache_mngr.c file
there are two parentheses bugs in libnl /lib/cache_mngr.c file. The parentheses doesn't make any sense, This will cause the variable err get a bool value, the correct value of variable err should be the return value of the function which can be any integer value. Signed-off-by: Song Li <Song.Li@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libnl/libnl/fix-lib-cache_mngr.c-two-parentheses-bugs.patch37
-rw-r--r--meta/recipes-support/libnl/libnl_3.2.22.bb3
2 files changed, 39 insertions, 1 deletions
diff --git a/meta/recipes-support/libnl/libnl/fix-lib-cache_mngr.c-two-parentheses-bugs.patch b/meta/recipes-support/libnl/libnl/fix-lib-cache_mngr.c-two-parentheses-bugs.patch
new file mode 100644
index 0000000000..6b8fa106ca
--- /dev/null
+++ b/meta/recipes-support/libnl/libnl/fix-lib-cache_mngr.c-two-parentheses-bugs.patch
@@ -0,0 +1,37 @@
+From 82fdf49c185fd5f3810781af9ef52aa6a52bf2df Mon Sep 17 00:00:00 2001
+From: "Song.Li" <Song.Li@windriver.com>
+Date: Thu, 28 Jun 2012 20:03:17 +0800
+Subject: [PATCH] fix lib/cache_mngr.c two parentheses bugs
+
+there are two parentheses bugs in libnl /lib/cache_mngr.c file.
+The parentheses doesn't make any sense,
+This will cause the variable err get a bool value,
+the correct value of variable err should be the return value
+of the function which can be any integer value.
+
+---
+ lib/cache_mngr.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Upstream-status: Pending
+
+diff --git a/lib/cache_mngr.c b/lib/cache_mngr.c
+index dae8768..57cc1f9 100644
+--- a/lib/cache_mngr.c
++++ b/lib/cache_mngr.c
+@@ -150,10 +150,10 @@ int nl_cache_mngr_alloc(struct nl_sock *sk, int protocol, int flags,
+ /* Required to receive async event notifications */
+ nl_socket_disable_seq_check(mngr->cm_sock);
+
+- if ((err = nl_connect(mngr->cm_sock, protocol) < 0))
++ if ((err = nl_connect(mngr->cm_sock, protocol)) < 0)
+ goto errout;
+
+- if ((err = nl_socket_set_nonblocking(mngr->cm_sock) < 0))
++ if ((err = nl_socket_set_nonblocking(mngr->cm_sock)) < 0)
+ goto errout;
+
+ NL_DBG(1, "Allocated cache manager %p, protocol %d, %d caches\n",
+--
+1.7.9.5
+
diff --git a/meta/recipes-support/libnl/libnl_3.2.22.bb b/meta/recipes-support/libnl/libnl_3.2.22.bb
index 36e98e1f43..30f85b2995 100644
--- a/meta/recipes-support/libnl/libnl_3.2.22.bb
+++ b/meta/recipes-support/libnl/libnl_3.2.22.bb
@@ -11,7 +11,8 @@ DEPENDS = "flex-native bison-native"
SRC_URI = "http://www.infradead.org/~tgr/${BPN}/files/${BP}.tar.gz \
file://fix-pktloc_syntax_h-race.patch \
- file://fix-pc-file.patch "
+ file://fix-pc-file.patch \
+ file://fix-lib-cache_mngr.c-two-parentheses-bugs.patch"
SRC_URI[md5sum] = "2e1c889494d274aca24ce5f6a748e66e"
SRC_URI[sha256sum] = "c7c5f267dfeae0c1a530bf96b71fb7c8dbbb07d54beef49b6712d8d6166f629b"