aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorMarko Lindqvist <cazfi74@gmail.com>2013-05-24 10:42:14 +0300
committerSaul Wold <sgw@linux.intel.com>2013-05-29 08:19:04 +0900
commit2d79a2f88b6676847ef868d3cc6475bd643b28a3 (patch)
tree32d5a36051df77d94288558bd9853711fbddbc2d /meta/recipes-support
parent4d5ac121db74ff662293d38ba453416b0a54d5fd (diff)
downloadopenembedded-core-2d79a2f88b6676847ef868d3cc6475bd643b28a3.tar.gz
curl: update to upstream version 7.30.0
0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch now part of upstream. Signed-off-by: Marko Lindqvist <cazfi74@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/curl/curl/0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch170
-rw-r--r--meta/recipes-support/curl/curl_7.30.0.bb (renamed from meta/recipes-support/curl/curl_7.29.0.bb)7
2 files changed, 3 insertions, 174 deletions
diff --git a/meta/recipes-support/curl/curl/0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch b/meta/recipes-support/curl/curl/0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch
deleted file mode 100644
index 914024e126..0000000000
--- a/meta/recipes-support/curl/curl/0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch
+++ /dev/null
@@ -1,170 +0,0 @@
-From 5887472e49ce6c14590760f0650775653045abb5 Mon Sep 17 00:00:00 2001
-From: Linus Nielsen Feltzing <linus@haxx.se>
-Date: Sun, 10 Feb 2013 22:57:58 +0100
-Subject: [PATCH] Fix NULL pointer reference when closing an unused multi
- handle.
-
-Upstream-Status: Backport
-https://github.com/bagder/curl/commit/da3fc1ee91de656a30f3a12de394bcba55119872
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-
----
- lib/multi.c | 8 +++++---
- tests/data/Makefile.am | 2 +-
- tests/data/test1508 | 31 +++++++++++++++++++++++++++++
- tests/libtest/Makefile.inc | 6 +++++-
- tests/libtest/lib1508.c | 49 ++++++++++++++++++++++++++++++++++++++++++++++
- 5 files changed, 91 insertions(+), 5 deletions(-)
- create mode 100644 tests/data/test1508
- create mode 100644 tests/libtest/lib1508.c
-
-diff --git a/lib/multi.c b/lib/multi.c
-index fa0afb9..706df23 100644
---- a/lib/multi.c
-+++ b/lib/multi.c
-@@ -1773,10 +1773,12 @@ CURLMcode curl_multi_cleanup(CURLM *multi_handle)
- /* Close all the connections in the connection cache */
- close_all_connections(multi);
-
-- multi->closure_handle->dns.hostcache = multi->hostcache;
-- Curl_hostcache_clean(multi->closure_handle);
-+ if(multi->closure_handle) {
-+ multi->closure_handle->dns.hostcache = multi->hostcache;
-+ Curl_hostcache_clean(multi->closure_handle);
-
-- Curl_close(multi->closure_handle);
-+ Curl_close(multi->closure_handle);
-+ }
- multi->closure_handle = NULL;
-
- Curl_hash_destroy(multi->sockhash);
-diff --git a/tests/data/Makefile.am b/tests/data/Makefile.am
-index d82534d..9f569a3 100644
---- a/tests/data/Makefile.am
-+++ b/tests/data/Makefile.am
-@@ -93,7 +93,7 @@ test1379 test1380 test1381 test1382 test1383 test1384 test1385 test1386 \
- test1387 test1388 test1389 test1390 test1391 test1392 test1393 \
- test1400 test1401 test1402 test1403 test1404 test1405 test1406 test1407 \
- test1408 test1409 test1410 test1411 test1412 test1413 \
--test1500 test1501 test1502 test1503 test1504 test1505 test1506 \
-+test1500 test1501 test1502 test1503 test1504 test1505 test1506 test1508 \
- test2000 test2001 test2002 test2003 test2004 test2005 test2006 test2007 \
- test2008 test2009 test2010 test2011 test2012 test2013 test2014 test2015 \
- test2016 test2017 test2018 test2019 test2020 test2021 test2022 \
-diff --git a/tests/data/test1508 b/tests/data/test1508
-new file mode 100644
-index 0000000..f8607e5
---- /dev/null
-+++ b/tests/data/test1508
-@@ -0,0 +1,31 @@
-+<testcase>
-+<info>
-+<keywords>
-+HTTP
-+multi
-+</keywords>
-+</info>
-+
-+# Client-side
-+<client>
-+<server>
-+none
-+</server>
-+<tool>
-+lib1508
-+</tool>
-+ <name>
-+Close a multi handle without using it
-+ </name>
-+ <command>
-+http://%HOSTIP:%HTTPPORT/path/1508
-+</command>
-+</client>
-+
-+# Verify data after the test has been "shot"
-+<verify>
-+<file name="log/stdout1508" mode="text">
-+We are done
-+</file>
-+</verify>
-+</testcase>
-diff --git a/tests/libtest/Makefile.inc b/tests/libtest/Makefile.inc
-index 82c265d..8bf2be4 100644
---- a/tests/libtest/Makefile.inc
-+++ b/tests/libtest/Makefile.inc
-@@ -23,7 +23,7 @@ noinst_PROGRAMS = chkhostname libauthretry libntlmconnect \
- lib582 lib583 lib585 lib586 lib587 \
- lib590 lib591 lib597 lib598 lib599 \
- \
-- lib1500 lib1501 lib1502 lib1503 lib1504 lib1505 lib1506
-+ lib1500 lib1501 lib1502 lib1503 lib1504 lib1505 lib1506 lib1508
-
- chkhostname_SOURCES = chkhostname.c ../../lib/curl_gethostname.c
- chkhostname_LDADD = @CURL_NETWORK_LIBS@
-@@ -312,3 +312,7 @@ lib1505_CPPFLAGS = $(AM_CPPFLAGS) -DLIB1505
- lib1506_SOURCES = lib1506.c $(SUPPORTFILES) $(TESTUTIL) $(WARNLESS)
- lib1506_LDADD = $(TESTUTIL_LIBS)
- lib1506_CPPFLAGS = $(AM_CPPFLAGS) -DLIB1506
-+
-+lib1508_SOURCES = lib1508.c $(SUPPORTFILES) $(TESTUTIL) $(WARNLESS)
-+lib1508_LDADD = $(TESTUTIL_LIBS)
-+lib1508_CPPFLAGS = $(AM_CPPFLAGS) -DLIB1508
-diff --git a/tests/libtest/lib1508.c b/tests/libtest/lib1508.c
-new file mode 100644
-index 0000000..72f26d1
---- /dev/null
-+++ b/tests/libtest/lib1508.c
-@@ -0,0 +1,49 @@
-+/***************************************************************************
-+ * _ _ ____ _
-+ * Project ___| | | | _ \| |
-+ * / __| | | | |_) | |
-+ * | (__| |_| | _ <| |___
-+ * \___|\___/|_| \_\_____|
-+ *
-+ * Copyright (C) 2013, Linus Nielsen Feltzing <linus@haxx.se>
-+ *
-+ * This software is licensed as described in the file COPYING, which
-+ * you should have received as part of this distribution. The terms
-+ * are also available at http://curl.haxx.se/docs/copyright.html.
-+ *
-+ * You may opt to use, copy, modify, merge, publish, distribute and/or sell
-+ * copies of the Software, and permit persons to whom the Software is
-+ * furnished to do so, under the terms of the COPYING file.
-+ *
-+ * This software is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY
-+ * KIND, either express or implied.
-+ *
-+ ***************************************************************************/
-+#include "test.h"
-+
-+#include "testutil.h"
-+#include "warnless.h"
-+#include "memdebug.h"
-+
-+int test(char *URL)
-+{
-+ int res = 0;
-+ CURLM *m = NULL;
-+
-+ (void)URL;
-+
-+ global_init(CURL_GLOBAL_ALL);
-+
-+ multi_init(m);
-+
-+test_cleanup:
-+
-+ /* proper cleanup sequence - type PB */
-+
-+ curl_multi_cleanup(m);
-+ curl_global_cleanup();
-+
-+ printf("We are done\n");
-+
-+ return res;
-+}
---
-1.8.1.5
-
diff --git a/meta/recipes-support/curl/curl_7.29.0.bb b/meta/recipes-support/curl/curl_7.30.0.bb
index 3669cb8524..fbfc211fd5 100644
--- a/meta/recipes-support/curl/curl_7.29.0.bb
+++ b/meta/recipes-support/curl/curl_7.30.0.bb
@@ -8,11 +8,10 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e66
DEPENDS = "zlib gnutls"
DEPENDS_class-native = "zlib-native openssl-native"
DEPENDS_class-nativesdk = "nativesdk-zlib"
-PR = "r1"
+PR = "r0"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://pkgconfig_fix.patch \
- file://0001-Fix-NULL-pointer-reference-when-closing-an-unused-mu.patch \
"
# curl likes to set -g0 in CFLAGS, so we stop it
@@ -20,8 +19,8 @@ SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
#
SRC_URI += " file://configure_ac.patch"
-SRC_URI[md5sum] = "fa5f37f38a8042020e292ce7ec5341ce"
-SRC_URI[sha256sum] = "9d78e8bac6fa101679ca82e72a24e55918c5d495d29acb1eff62610929d3832f"
+SRC_URI[md5sum] = "0db5ec03a5001b42a2edc03bf63b5ceb"
+SRC_URI[sha256sum] = "6b1c410387bea82601baec85d6aa61955794672e36766407e99ade8d55aaaf11"
inherit autotools pkgconfig binconfig