aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorvictor <v.mayoralv@gmail.com>2013-07-03 15:04:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-05 15:26:20 +0100
commit20b9151f877978c086dcc8cbae7e0d9c9e89a45d (patch)
treeb2b2b85fc55151dd8e590820b409e10565ea07cf /meta/recipes-support
parent9a6cf08afd81c95abf13e6cf5e43bb8cd777edd9 (diff)
downloadopenembedded-core-20b9151f877978c086dcc8cbae7e0d9c9e89a45d.tar.gz
apr_cv_mutex_recursive=yes added to apr_1.4.6.bb to make rosnodes work
Working with the meta-ros project we detected that the ROS nodes didn't launch properly the reason was that by default apr_cv_mutex_recursive in apr is set to no and this leads to the APRENOTIMPL return value of apr_thread_mutex_create in thread_mutex.c when APR_THREAD_MUTEX_NESTED is requested via flags. Added CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes" to sources/openembedded-core/meta/recipes-support/apr/apr_1.4.6.bb to fix this issue. It has also been removed the mention of this variable in meta/site/powerpc32-linux. Signed-off-by: VĂ­ctor Mayoral Vilches <v.mayoralv@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/apr/apr_1.4.6.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.4.6.bb b/meta/recipes-support/apr/apr_1.4.6.bb
index 77dffee12c..fb87d68c9f 100644
--- a/meta/recipes-support/apr/apr_1.4.6.bb
+++ b/meta/recipes-support/apr/apr_1.4.6.bb
@@ -23,6 +23,9 @@ inherit autotools lib_package binconfig multilib_header
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
+CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
+
do_configure_prepend() {
cd ${S}
./buildconf