aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-02-15 22:04:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-18 08:37:03 +0000
commit644c307f63f0f0b7e97140850d3d1d2124b11b1b (patch)
tree9dbec1b781596d66c00eaf93fb3c93fcbe154ca5 /meta/recipes-support/icu
parent315a71e00928fea6715087b1ce66f8a8a91d5fe0 (diff)
downloadopenembedded-core-644c307f63f0f0b7e97140850d3d1d2124b11b1b.tar.gz
icu: Disable the default LDFLAGSICUDT for target compile
By default LDFLAGSICUDT=-nodefaultlibs -nostdlib for Linux which means DT_NEEDED section for libicu will not be populated with dependencies when we reset it to be empty then the default libraries it needs are added to DT_NEEDED section in ELF header This patch is a workaround as I consider it for now, since it could be a problem in glibc dynamic loader for arm (especially for hf case) where its unable to load shared objects which dont have any dependencies expressed in DT_NEEDED segment. here is when LDFLAGSICUDT=-nodefaultlibs -nostdlib Dynamic section at offset 0x1549c10 contains 8 entries: Tag Type Name/Value 0x0000000e (SONAME) Library soname: [libicudata.so.51] 0x00000010 (SYMBOLIC) 0x0 0x6ffffef5 (GNU_HASH) 0xf8 0x00000005 (STRTAB) 0x188 0x00000006 (SYMTAB) 0x138 0x0000000a (STRSZ) 54 (bytes) 0x0000000b (SYMENT) 16 (bytes) 0x00000000 (NULL) 0x0 here is one with LDFLAGSICUDT empty Dynamic section at offset 0x154a014 contains 22 entries: Tag Type Name/Value 0x00000001 (NEEDED) Shared library: [libc.so.6] 0x0000000e (SONAME) Library soname: [libicudata.so.51] 0x00000010 (SYMBOLIC) 0x0 0x0000000c (INIT) 0x33c 0x0000000d (FINI) 0x500 0x6ffffef5 (GNU_HASH) 0xf8 0x00000005 (STRTAB) 0x204 0x00000006 (SYMTAB) 0x144 0x0000000a (STRSZ) 192 (bytes) 0x0000000b (SYMENT) 16 (bytes) 0x00000003 (PLTGOT) 0x154a0f8 0x00000002 (PLTRELSZ) 16 (bytes) 0x00000014 (PLTREL) REL 0x00000017 (JMPREL) 0x32c 0x00000011 (REL) 0x2fc 0x00000012 (RELSZ) 48 (bytes) 0x00000013 (RELENT) 8 (bytes) 0x6ffffffe (VERNEED) 0x2dc 0x6fffffff (VERNEEDNUM) 1 0x6ffffff0 (VERSYM) 0x2c4 0x6ffffffa (RELCOUNT) 1 0x00000000 (NULL) 0x0 btw. ldd reveals the fist one to be static library while the second one is detected as shared library. This could be a clue into how elf headers are being interpreted by dynamic loader. The data seems to be all static in libicudata which could load it quicker and thats what could be confusing dynamic linker ..may be Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-support/icu')
-rw-r--r--meta/recipes-support/icu/icu-51.2/0001-Disable-LDFLAGSICUDT-for-Linux.patch28
-rw-r--r--meta/recipes-support/icu/icu_51.2.bb3
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-support/icu/icu-51.2/0001-Disable-LDFLAGSICUDT-for-Linux.patch b/meta/recipes-support/icu/icu-51.2/0001-Disable-LDFLAGSICUDT-for-Linux.patch
new file mode 100644
index 0000000000..2968d571bb
--- /dev/null
+++ b/meta/recipes-support/icu/icu-51.2/0001-Disable-LDFLAGSICUDT-for-Linux.patch
@@ -0,0 +1,28 @@
+From 0c82d6aa02c08e41b13c83b14782bd7024e25d59 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 15 Feb 2014 21:06:42 +0000
+Subject: [PATCH] Disable LDFLAGSICUDT for Linux
+
+Upstream-Status: Inappropriate [ OE Configuration ]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ source/config/mh-linux | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/config/mh-linux b/config/mh-linux
+index 366f0cc..2689aab 100644
+--- a/config/mh-linux
++++ b/config/mh-linux
+@@ -21,7 +21,7 @@ LD_RPATH= -Wl,-zorigin,-rpath,'$$'ORIGIN
+ LD_RPATH_PRE = -Wl,-rpath,
+
+ ## These are the library specific LDFLAGS
+-LDFLAGSICUDT=-nodefaultlibs -nostdlib
++# LDFLAGSICUDT=-nodefaultlibs -nostdlib
+
+ ## Compiler switch to embed a library name
+ # The initial tab in the next line is to prevent icu-config from reading it.
+--
+1.7.10.4
+
diff --git a/meta/recipes-support/icu/icu_51.2.bb b/meta/recipes-support/icu/icu_51.2.bb
index aabe07b841..2d1fd42924 100644
--- a/meta/recipes-support/icu/icu_51.2.bb
+++ b/meta/recipes-support/icu/icu_51.2.bb
@@ -9,5 +9,8 @@ SRC_URI = "${BASE_SRC_URI} \
file://add_buffer_length_check_to_UTF_16_or_32_detector.patch \
"
+SRC_URI_append_class-target = "\
+ file://0001-Disable-LDFLAGSICUDT-for-Linux.patch \
+ "
SRC_URI[md5sum] = "072e501b87065f3a0ca888f1b5165709"
SRC_URI[sha256sum] = "deb027a05f1b3bec03298b96fb93b28c84e9683c22e6f94effa67fdc7bd704cc"