aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-12-18 21:14:05 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-19 17:50:05 +0000
commit12a4d6e1143f94b53ead67ec75103505fdb110fd (patch)
treec9b8ed828f2ef827da41fc6c62d3213c552710e9 /meta/recipes-support/icu
parentfff3164c4b6a8c4ffa07bc6a26162c9e99c2531e (diff)
downloadopenembedded-core-12a4d6e1143f94b53ead67ec75103505fdb110fd.tar.gz
icu: reduce what's needed for cross tools
The ICU Update copied to complete source tree over, it only needed a couple of binaries and libraries, so only copy those. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/icu')
-rw-r--r--meta/recipes-support/icu/icu.inc16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta/recipes-support/icu/icu.inc b/meta/recipes-support/icu/icu.inc
index f7257d13e8..1329635817 100644
--- a/meta/recipes-support/icu/icu.inc
+++ b/meta/recipes-support/icu/icu.inc
@@ -7,7 +7,7 @@ DEPENDS = "icu-native"
DEPENDS_class-native = ""
S = "${WORKDIR}/icu/source"
-STAGING_ICU_SOURCE_DIR_NATIVE = "${STAGING_DATADIR_NATIVE}/icu"
+STAGING_ICU_DIR_NATIVE = "${STAGING_DATADIR_NATIVE}/${BPN}/${PV}"
PARALLEL_MAKE = ""
FULL_OPTIMIZATION_arm = "-Os"
@@ -17,7 +17,7 @@ inherit autotools pkgconfig binconfig
# ICU needs the native build directory as an argument to its --with-cross-build option when
# cross-compiling. Taken the situation that different builds may share a common sstate-cache
# into consideration, the native build directory needs to be staged.
-EXTRA_OECONF = "--with-cross-build=${STAGING_DATADIR_NATIVE}/icu/source"
+EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
EXTRA_OECONF_class-native = ""
# ICU puts custom m4 autoconf functions in aclocal.m4.
@@ -29,11 +29,13 @@ do_configure_prepend() {
[ -f acinclude.m4 ] || cp aclocal.m4 acinclude.m4
}
-do_install_append() {
- if [ ${PN} == 'icu-native' ]; then
- mkdir -p ${D}/${STAGING_ICU_SOURCE_DIR_NATIVE}
- cp -r ${S} ${D}/${STAGING_ICU_SOURCE_DIR_NATIVE}
- fi
+do_install_append_class-native() {
+ mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config
+ cp -r ${S}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config
+ cp -r ${S}/lib ${D}/${STAGING_ICU_DIR_NATIVE}
+ cp -r ${S}/bin ${D}/${STAGING_ICU_DIR_NATIVE}
+ cp -r ${S}/tools ${D}/${STAGING_ICU_DIR_NATIVE}
+
}
PACKAGES =+ "libicudata libicuuc libicui18n libicule libiculx libicutu libicuio"