aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 02:05:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 13:17:39 +0000
commit0525a1556ab3d25d9e6bda2fc3c8e40123825109 (patch)
treeadea96ff41ecc7c38a9020802e2cb2afb0d8e539 /meta/recipes-support/icu
parentbe335eab958546c8ae39b879767dd30f1e95a701 (diff)
downloadopenembedded-core-0525a1556ab3d25d9e6bda2fc3c8e40123825109.tar.gz
icu: Fix case where ${B} != ${S}
Fix out of tree builds by fixing cwd assumptions and using correct full paths where needed, or just simply the correct paths. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/icu')
-rw-r--r--meta/recipes-support/icu/icu.inc10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-support/icu/icu.inc b/meta/recipes-support/icu/icu.inc
index 64b3edf3ca..d7cb84a400 100644
--- a/meta/recipes-support/icu/icu.inc
+++ b/meta/recipes-support/icu/icu.inc
@@ -27,15 +27,15 @@ EXTRA_OECONF_class-native = ""
# This is a bug of ICU. See bug reference:
# http://bugs.icu-project.org/trac/ticket/9790
do_configure_prepend() {
- [ -f acinclude.m4 ] || cp aclocal.m4 acinclude.m4
+ [ -f ${S}/acinclude.m4 ] || cp ${S}/aclocal.m4 ${S}/acinclude.m4
}
do_install_append_class-native() {
mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config
- cp -r ${S}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config
- cp -r ${S}/lib ${D}/${STAGING_ICU_DIR_NATIVE}
- cp -r ${S}/bin ${D}/${STAGING_ICU_DIR_NATIVE}
- cp -r ${S}/tools ${D}/${STAGING_ICU_DIR_NATIVE}
+ cp -r ${B}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config
+ cp -r ${B}/lib ${D}/${STAGING_ICU_DIR_NATIVE}
+ cp -r ${B}/bin ${D}/${STAGING_ICU_DIR_NATIVE}
+ cp -r ${B}/tools ${D}/${STAGING_ICU_DIR_NATIVE}
}