summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bash-completion/bash-completion_2.13.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-09 15:09:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 07:38:37 +0100
commita2cbd936ea59cd47accc61b164e6d8b44b63a5cf (patch)
treef77cfe7cd097266671a48f8c3bc8dceb60952681 /meta/recipes-support/bash-completion/bash-completion_2.13.0.bb
parenta5f05da60ca888456900f9fb0a52ef07db754c06 (diff)
downloadopenembedded-core-a2cbd936ea59cd47accc61b164e6d8b44b63a5cf.tar.gz
bash-completion: upgrade 2.12.0 -> 2.13.0
Changelog: =========== ### Features ------------ -Complete protocols for --proto-default -Add completion for netconf subcommand -Complete commands for netns exec -Complete help for unknown subcommands -Complete ip link property -Complete link types for address show -Complete neigh show and flush -Complete stats subcommand -Create function to get link types -add fallback 3rd party completion loader -also suggest *.rss files ### Bug Fixes -------------- -fix regression of unwanted trailing colons -Complete addrlabel add/del properties -Complete ip delete with type correctly -Complete more variations of subcommands -Complete netns attach subcommand -Complete only relevant addrlabel subcmds -Keep completing after -netns name -Quote all instantiation of ip as "$1" -Quote network namespace names -include api-and-naming.md in dist Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/bash-completion/bash-completion_2.13.0.bb')
-rw-r--r--meta/recipes-support/bash-completion/bash-completion_2.13.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/bash-completion/bash-completion_2.13.0.bb b/meta/recipes-support/bash-completion/bash-completion_2.13.0.bb
new file mode 100644
index 0000000000..f75d61e219
--- /dev/null
+++ b/meta/recipes-support/bash-completion/bash-completion_2.13.0.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Programmable Completion for Bash 4"
+DESCRIPTION = "Collection of command line command completions for the Bash shell, \
+collection of helper functions to assist in creating new completions, \
+and set of facilities for loading completions automatically on demand, as well \
+as installing them."
+
+HOMEPAGE = "https://github.com/scop/bash-completion"
+BUGTRACKER = "https://github.com/scop/bash-completion/issues"
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SECTION = "console/utils"
+
+SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz"
+
+SRC_URI[sha256sum] = "c5f99a39e40f0d154c03ff15438e87ece1f5ac666336a4459899e2ff4bedf3d1"
+GITHUB_BASE_URI = "https://github.com/scop/bash-completion/releases"
+
+PARALLEL_MAKE = ""
+
+inherit autotools github-releases
+
+do_install:append() {
+ # compatdir
+ install -d ${D}${sysconfdir}/bash_completion.d/
+ echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
+
+}
+
+RDEPENDS:${PN} = "bash"
+
+# Some recipes are providing ${PN}-bash-completion packages
+PACKAGES =+ "${PN}-extra"
+FILES:${PN}-extra = "${datadir}/${BPN}/completions/ \
+ ${datadir}/${BPN}/helpers/"
+
+BBCLASSEXTEND = "nativesdk"