aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-06-26 17:26:50 +0100
committerSaul Wold <sgw@linux.intel.com>2012-07-18 00:34:36 -0700
commitcd9a97c063a6c58b022d95ca9de8bcce784f1d3a (patch)
tree0468f0d91605439612745115a74851b4d7232bda /meta/recipes-sato
parent9073ec0610a9e28c4b2bc90ace7a6b1c0cc99f75 (diff)
downloadopenembedded-core-cd9a97c063a6c58b022d95ca9de8bcce784f1d3a.tar.gz
web-webkit: don't link using g++, it's not needed anymore
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/web/web-webkit/link-with-g++.patch35
-rw-r--r--meta/recipes-sato/web/web-webkit_git.bb9
2 files changed, 2 insertions, 42 deletions
diff --git a/meta/recipes-sato/web/web-webkit/link-with-g++.patch b/meta/recipes-sato/web/web-webkit/link-with-g++.patch
deleted file mode 100644
index e0c678457a..0000000000
--- a/meta/recipes-sato/web/web-webkit/link-with-g++.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-The main webkit library links against stdc++ so we need to use g++ for
-linking. The easiest way to achieve this is to add a dummy cpp file.
-This also means we have to add AC_PROG_CXX else libtool 2.2.2 gets upset.
-
-RP - 14/4/08
-
-Upstream-Status: Inappropriate [configuration]
-
---- webkit.orig/src/Makefile.am
-+++ webkit/src/Makefile.am
-@@ -1,11 +1,11 @@
- AM_CPPFLAGS=-DPKGDATADIR=\"$(pkgdatadir)\"
- AM_CFLAGS = -Wall -export-dynamic $(WEB_CFLAGS)
-
- bin_PROGRAMS = web2
-
--web2_SOURCES = web2.h web2-main.c web2-utils.c web2-utils.h
-+web2_SOURCES = web2.h web2-main.c web2-utils.c web2-utils.h dummy.cpp
- web2_LDADD = $(WEB_LIBS)
-
- MAINTAINERCLEANFILES = config.h.in Makefile.in
-
- uidir = $(pkgdatadir)
-Index: webkit/configure.ac
-===================================================================
---- webkit.orig/configure.ac 2008-04-14 22:15:25.000000000 +0100
-+++ webkit/configure.ac 2008-04-14 22:16:31.000000000 +0100
-@@ -7,6 +7,7 @@
-
- AC_ISC_POSIX
- AC_PROG_CC
-+AC_PROG_CXX
- AC_STDC_HEADERS
- AC_PROG_LIBTOOL
-
diff --git a/meta/recipes-sato/web/web-webkit_git.bb b/meta/recipes-sato/web/web-webkit_git.bb
index dae7faf6da..0c79324791 100644
--- a/meta/recipes-sato/web/web-webkit_git.bb
+++ b/meta/recipes-sato/web/web-webkit_git.bb
@@ -13,10 +13,9 @@ RRECOMMENDS_${PN} += "glib-networking"
SRCREV = "b0676c190f876cbdb1df202fbcec42f212374503"
PV = "0.1+git${SRCPV}"
-PR = "r1"
+PR = "r2"
-SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
- file://link-with-g++.patch"
+SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git"
S = "${WORKDIR}/git"
@@ -24,8 +23,4 @@ EXTRA_OECONF = "--enable-libowl"
inherit autotools pkgconfig
-do_configure_prepend() {
- touch ${S}/src/dummy.cpp
-}
-
FILES_${PN} += "${datadir}/web2"