aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-10-04 12:37:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-04 14:04:09 +0100
commit8848ea6793ddaab61c9dad250ec578d68d7d087d (patch)
tree6e881a8f97bd6d173eb137615bec69c272af9547 /meta/recipes-sato
parent9d98dbdae4c05fcf50d546f554a04dc3f0bd66c3 (diff)
downloadopenembedded-core-8848ea6793ddaab61c9dad250ec578d68d7d087d.tar.gz
shutdown-desktop: ensure the postinst script succeeds
When the hostname isn't qemuarm the grep fails so the postinst fails. Stop this happening by explicitly evaluating true. [YOCTO #3224] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
index d0f507e673..c5096c1530 100644
--- a/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
+++ b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
@@ -5,6 +5,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
SRC_URI = "file://shutdown.desktop"
+PR = "r1"
+
S = "${WORKDIR}"
do_install() {
@@ -14,7 +16,8 @@ do_install() {
pkg_postinst_${PN} () {
grep -q qemuarm $D${sysconfdir}/hostname && \
- sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
+ sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/' \
+ || true
}
inherit allarch