aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-07-26 18:16:14 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:50 -0700
commit65fca4458cfe1d647c7ea1d4588dc449739a73eb (patch)
tree66ab6e610c025dbf9fcd5480324c043e06125182 /meta/recipes-sato
parent3a3ae22bc0be5b36e0400986930f30c22a61a74e (diff)
downloadopenembedded-core-65fca4458cfe1d647c7ea1d4588dc449739a73eb.tar.gz
packagegroup-*: change to inherit from packagegroup.bbclass
Also clean out items already handled by that class (dev/dbg packages, ALLOW_EMPTY, etc.) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb8
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb8
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11.bb10
3 files changed, 4 insertions, 22 deletions
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb
index 4f3bb47000..432d99d0ca 100644
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb
@@ -8,18 +8,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PR = "r1"
-PACKAGES = "\
- packagegroup-core-x11-mini \
- packagegroup-core-x11-mini-dbg \
- packagegroup-core-x11-mini-dev \
- "
+inherit packagegroup
PACKAGE_ARCH = "${MACHINE_ARCH}"
XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
-ALLOW_EMPTY = "1"
-
ROOTLESS_X = "1"
# xserver-common, x11-common
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
index 380584e223..f38e0d2800 100644
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
@@ -8,16 +8,10 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PR = "r32"
-PACKAGES = "\
- packagegroup-core-x11-sato \
- packagegroup-core-x11-sato-dbg \
- packagegroup-core-x11-sato-dev \
- "
+inherit packagegroup
PACKAGE_ARCH = "${MACHINE_ARCH}"
-ALLOW_EMPTY = "1"
-
NETWORK_MANAGER ?= "connman-gnome"
NETWORK_MANAGER_libc-uclibc = ""
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
index 4c16c461a3..3fe5caee93 100644
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
@@ -8,24 +8,18 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PR = "r36"
+inherit packagegroup
+
PACKAGES = "\
packagegroup-core-apps-x11-core \
- packagegroup-core-apps-x11-core-dbg \
- packagegroup-core-apps-x11-core-dev \
packagegroup-core-apps-x11-games \
- packagegroup-core-apps-x11-games-dbg \
- packagegroup-core-apps-x11-games-dev \
packagegroup-core-x11-base \
- packagegroup-core-x11-base-dbg \
- packagegroup-core-x11-base-dev \
"
PACKAGE_ARCH = "${MACHINE_ARCH}"
XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
-ALLOW_EMPTY = "1"
-
# pcmanfm doesn't work on mips/powerpc
FILEMANAGER ?= "pcmanfm"
FILEMANAGER_mips ?= ""