aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-08-10 15:45:06 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-17 18:04:09 +0100
commit65c62f8734dc56d411d33f638716e99790f2895f (patch)
tree8ffd9718602a82dc1f6580b19d45bebdd60bd3a4 /meta/recipes-sato
parentfbff096fd1168ec8147fb348fb36ecafcaefef19 (diff)
downloadopenembedded-core-65c62f8734dc56d411d33f638716e99790f2895f.tar.gz
owl-video: patches pushed upstream, so bump srcrev
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/owl-video-widget/owl-video/gtk_multithread_safe.patch40
-rw-r--r--meta/recipes-sato/owl-video-widget/owl-video/make-382.patch17
-rw-r--r--meta/recipes-sato/owl-video-widget/owl-video_git.bb8
3 files changed, 3 insertions, 62 deletions
diff --git a/meta/recipes-sato/owl-video-widget/owl-video/gtk_multithread_safe.patch b/meta/recipes-sato/owl-video-widget/owl-video/gtk_multithread_safe.patch
deleted file mode 100644
index 437f72be86..0000000000
--- a/meta/recipes-sato/owl-video-widget/owl-video/gtk_multithread_safe.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Use gdk_threads_enter/gdk_threads_leave to ensure gtk multithread safe
-
-If the video player tries to play an unknown type file, it will enter
-the error_cb() function, which is called in another thread.
-Use gdk_threads_enter/gdk_threads_leave to ensure the safe of gtk
-multi-thread operation.
-
-Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-
-Upstream-Status: Pending
-
-diff -ruN video-orig/src/video.c video/src/video.c
---- video-orig/src/video.c 2010-10-15 16:07:26.522346398 +0800
-+++ video/src/video.c 2010-10-15 16:25:51.780296717 +0800
-@@ -96,6 +96,7 @@
- {
- GtkWidget *dialog;
-
-+ gdk_threads_enter();
- dialog = gtk_message_dialog_new (data->window,
- GTK_DIALOG_NO_SEPARATOR,
- GTK_MESSAGE_ERROR,
-@@ -103,6 +104,7 @@
- error->message);
- gtk_dialog_run (GTK_DIALOG (dialog));
- gtk_widget_destroy (dialog);
-+ gdk_threads_leave();
- }
-
- /**
-@@ -606,7 +608,9 @@
-
- gtk_widget_show_all (GTK_WIDGET (data->window));
-
-+ gdk_threads_enter();
- gtk_main ();
-+ gdk_threads_leave();
-
- /**
- * Cleanup.
diff --git a/meta/recipes-sato/owl-video-widget/owl-video/make-382.patch b/meta/recipes-sato/owl-video-widget/owl-video/make-382.patch
deleted file mode 100644
index d219c31858..0000000000
--- a/meta/recipes-sato/owl-video-widget/owl-video/make-382.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Make 3.82 is much stricter and demands tabs. Obey.
-
-JL - 15/12/10
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: video/Makefile.am
-===================================================================
---- video.orig/Makefile.am
-+++ video/Makefile.am
-@@ -4,5 +4,5 @@ SUBDIRS = src
- MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub configure depcomp intltool-extract intltool-merge intltool-update install-sh ltmain.sh Makefile.in missing
-
- snapshot:
-- $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
-+ $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
-
diff --git a/meta/recipes-sato/owl-video-widget/owl-video_git.bb b/meta/recipes-sato/owl-video-widget/owl-video_git.bb
index bc63273641..ae083839f3 100644
--- a/meta/recipes-sato/owl-video-widget/owl-video_git.bb
+++ b/meta/recipes-sato/owl-video-widget/owl-video_git.bb
@@ -8,22 +8,20 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ac14b7ca45afea5af040da54db270eb0 \
SECTION = "x11"
DEPENDS = "libowl-av"
-SRCREV = "f133472318970796fae1ea3e98ac062156768baf"
+SRCREV = "07ab48f331a5e6e0d169e4892c7eb1fc22dc0b9d"
PV = "0.1+git${SRCPV}"
-PR = "r1"
+PR = "r2"
S = "${WORKDIR}/git"
SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
- file://gtk_multithread_safe.patch \
file://owl-video-widget.png \
file://stock_media-play.png \
file://stock_volume-0.png \
file://stock_volume-min.png \
file://stock_volume-med.png \
file://stock_volume-max.png \
- file://owl-video-widget.desktop \
- file://make-382.patch"
+ file://owl-video-widget.desktop"
inherit autotools pkgconfig