aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-08-10 15:47:00 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-17 18:04:09 +0100
commit5b0d8cb8463da423035484f42659926b472c53b3 (patch)
tree362bbb12e45ce33ecc98897bf780bd873d715f43 /meta/recipes-sato
parent65c62f8734dc56d411d33f638716e99790f2895f (diff)
downloadopenembedded-core-5b0d8cb8463da423035484f42659926b472c53b3.tar.gz
libowl-av: patches merged upstream, bump srcrev
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/owl-video-widget/libowl-av/gst_change_state.patch42
-rw-r--r--meta/recipes-sato/owl-video-widget/libowl-av/make-382.patch13
-rw-r--r--meta/recipes-sato/owl-video-widget/libowl-av_git.bb8
3 files changed, 3 insertions, 60 deletions
diff --git a/meta/recipes-sato/owl-video-widget/libowl-av/gst_change_state.patch b/meta/recipes-sato/owl-video-widget/libowl-av/gst_change_state.patch
deleted file mode 100644
index 5bc279a019..0000000000
--- a/meta/recipes-sato/owl-video-widget/libowl-av/gst_change_state.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Fix music player crash if adding unknown type files.
-
-Using bus message to call function flush_head/feed_head in main thread
-to protect private data operation.
-
-A better fix may be to listen to bus message "CODEC_NOT_FOUND" and
-"MISSING_PLUGIN" directly to avoid hooking into "unknown-type" signal.
-We will revisit it in next period.
-
-Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-
-Upstream-Status: Pending
-
-diff -ruN libowl-av-orig/libowl-av/owl-tag-reader.c libowl-av/libowl-av/owl-tag-reader.c
---- libowl-av-orig/libowl-av/owl-tag-reader.c 2010-10-12 14:30:26.000000000 +0800
-+++ libowl-av/libowl-av/owl-tag-reader.c 2010-10-12 14:32:39.000000000 +0800
-@@ -300,13 +300,23 @@
- GstCaps *caps,
- OwlTagReader *tag_reader)
- {
-+ GstMessage *message;
-+ GstBus *bus;
-+
- tag_reader->priv->current_error =
- g_error_new (OWL_TAG_READER_ERROR,
- OWL_TAG_READER_ERROR_UNKNOWN_TYPE,
- "Unknown type");
-
-- flush_head (tag_reader);
-- feed_head (tag_reader);
-+ /**
-+ * Post a message to the bus, as we are in another thread here.
-+ **/
-+ message = gst_message_new_error(GST_OBJECT (decodebin),
-+ tag_reader->priv->current_error, NULL);
-+
-+ bus = gst_pipeline_get_bus (GST_PIPELINE (tag_reader->priv->pipeline));
-+ gst_bus_post (bus, message);
-+ gst_object_unref (GST_OBJECT (bus));
- }
-
- /**
diff --git a/meta/recipes-sato/owl-video-widget/libowl-av/make-382.patch b/meta/recipes-sato/owl-video-widget/libowl-av/make-382.patch
deleted file mode 100644
index a8be781dc9..0000000000
--- a/meta/recipes-sato/owl-video-widget/libowl-av/make-382.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Upstream-Status: Inappropriate [configuration]
-
-Index: libowl-av/Makefile.am
-===================================================================
---- libowl-av.orig/Makefile.am
-+++ libowl-av/Makefile.am
-@@ -14,5 +14,5 @@ EXTRA_DIST = libowl-av.pc.in libowl-av.v
- MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub configure depcomp intltool-extract intltool-merge intltool-update install-sh ltmain.sh Makefile.in missing
-
- snapshot:
-- $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
-+ $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
-
diff --git a/meta/recipes-sato/owl-video-widget/libowl-av_git.bb b/meta/recipes-sato/owl-video-widget/libowl-av_git.bb
index 4413d38839..62a4a7dccf 100644
--- a/meta/recipes-sato/owl-video-widget/libowl-av_git.bb
+++ b/meta/recipes-sato/owl-video-widget/libowl-av_git.bb
@@ -12,14 +12,12 @@ DEPENDS = "gtk+ gstreamer gst-plugins-base"
RDEPENDS_${PN} = "gst-meta-base"
RRECOMMENDS_${PN} = "gst-meta-audio gst-meta-video"
-SRCREV = "1379fd230a32509e94971961183f1031f469737a"
+SRCREV = "03030c41ea578cfa74a2ffceb875675b248318ae"
PV = "0.1+git${SRCPV}"
-PR = "r2"
+PR = "r3"
-SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
- file://gst_change_state.patch \
- file://make-382.patch"
+SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git"
S = "${WORKDIR}/git"