aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-30 12:04:18 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:51 -0700
commit0cc9ced7d96b960994b0671095bc74becfc55e2c (patch)
treeb86c71f0b80d33fd59a2efbad477068dedb4cbf8 /meta/recipes-sato
parent9e3b208cce1a673619d82b672c7b83e6e80215cb (diff)
downloadopenembedded-core-0cc9ced7d96b960994b0671095bc74becfc55e2c.tar.gz
packagegroup-core-x11*: adjust X11 package groups
Now the Sato pieces have been moved out, rebase packagegroup-core-x11 on packagegroup-x11-mini but using the structure/contents of meta-oe's task-x11 so that it can replace that; rename packagegroup-core-x11-mini to packagegroup-core-x11-base and pull in the xserver/utils packages via packagegroup-core-x11, and move both of these recipes under recipes-graphics. x11-mini is renamed to x11-base as it's what people should build on top of and since x11-mini is newer, the corresponding IMAGE_FEATURES item is less likely to be used in existing user recipes. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/images/core-image-sato.bb2
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb39
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11.bb45
3 files changed, 2 insertions, 84 deletions
diff --git a/meta/recipes-sato/images/core-image-sato.bb b/meta/recipes-sato/images/core-image-sato.bb
index 76f90817ad..6b6c7611bc 100644
--- a/meta/recipes-sato/images/core-image-sato.bb
+++ b/meta/recipes-sato/images/core-image-sato.bb
@@ -7,3 +7,5 @@ IMAGE_FEATURES += "apps-console-core package-management x11-base x11-sato ssh-se
LICENSE = "MIT"
inherit core-image
+
+IMAGE_INSTALL += "packagegroup-core-x11-sato-games"
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb
deleted file mode 100644
index 432d99d0ca..0000000000
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-# Copyright (C) 2011 Intel Corporation
-#
-
-DESCRIPTION = "Tasks for core X11 applications"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r1"
-
-inherit packagegroup
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
-
-ROOTLESS_X = "1"
-
-# xserver-common, x11-common
-VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
-
-# elsa, xserver-nodm-init
-VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
-
-
-RDEPENDS_packagegroup-core-x11-mini = "\
- dbus \
- pointercal \
- matchbox-terminal \
- matchbox-wm \
- mini-x-session \
- ${XSERVER} \
- ${VIRTUAL-RUNTIME_xserver_common} \
- ${VIRTUAL-RUNTIME_graphical_init_manager} \
- liberation-fonts \
- xauth \
- xhost \
- xset \
- xrandr"
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
deleted file mode 100644
index b69cc50d33..0000000000
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
+++ /dev/null
@@ -1,45 +0,0 @@
-#
-# Copyright (C) 2011 Intel Corporation
-#
-
-DESCRIPTION = "Tasks for core X11 applications"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r36"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-core-x11-base \
- "
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
-
-# xserver-common, x11-common
-VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
-
-# elsa, xserver-nodm-init
-VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
-
-
-RDEPENDS_packagegroup-core-x11-base = "\
- dbus \
- pointercal \
- matchbox-wm \
- matchbox-keyboard \
- matchbox-keyboard-applet \
- matchbox-keyboard-im \
- matchbox-panel-2 \
- matchbox-desktop \
- matchbox-session \
- ${XSERVER} \
- ${VIRTUAL-RUNTIME_xserver_common} \
- ${VIRTUAL-RUNTIME_graphical_init_manager} \
- liberation-fonts \
- xauth \
- xhost \
- xset \
- xrandr"