summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-03 14:37:21 +0100
committerAnuj Mittal <anuj.mittal@intel.com>2020-12-10 09:12:25 +0800
commitb1f2ad7b46e012b653682cb41973384ac5bbdb67 (patch)
treea6ef537fd31e651cb38b5754f5aac878db4102c0 /meta/recipes-sato/webkit
parent5b9b559ceb0ef11175a37106abf8378cacda352a (diff)
downloadopenembedded-core-b1f2ad7b46e012b653682cb41973384ac5bbdb67.tar.gz
webkitgtk: fix reproducibility
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 1e7c673ab8d14766190843c6d8747510b37c71bf) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'meta/recipes-sato/webkit')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.28.4.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb b/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb
index 34b14f86ea..45b3ee2bce 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb
@@ -134,3 +134,15 @@ GI_DATA_ENABLED_libc-musl_armv7ve = "False"
# Can't be built with ccache
CCACHE_DISABLE = "1"
+
+PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
+src_package_preprocess () {
+ # Trim build paths from comments in generated sources to ensure reproducibility
+ sed -i -e "s,${WORKDIR},,g" \
+ ${B}/DerivedSources/webkit2gtk/webkit2/*.cpp \
+ ${B}/DerivedSources/ForwardingHeaders/JavaScriptCore/*.h \
+ ${B}/DerivedSources/JavaScriptCore/*.h \
+ ${B}/DerivedSources/JavaScriptCore/yarr/*.h \
+ ${B}/DerivedSources/MiniBrowser/*.c
+}
+