aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2012-06-12 05:39:43 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-13 11:51:02 +0100
commit2782caf0f07f61cab92d2981c5e82914f22bd700 (patch)
tree1aa7e3ff8f859103d129609d7bf7190f9626dfdc /meta/recipes-sato/webkit
parent28087e7a9ddfd2d118aa907a29ed522bb8cbfc16 (diff)
downloadopenembedded-core-2782caf0f07f61cab92d2981c5e82914f22bd700.tar.gz
webkit-gtk: Apply work around for all PowerPC targets
The current patch for bug #1570 only applies to qemuppc but should be applicable for all PowerPC targets. Also update the patch so that only one language backend, either ICU or PANGO, is built. Also remove some old customizations (dependencies on darwin) as these should now be handled in a layer specific .bbappend file. Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Diffstat (limited to 'meta/recipes-sato/webkit')
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_svn.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_svn.bb b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
index 9381486e20..716afceda2 100644
--- a/meta/recipes-sato/webkit/webkit-gtk_svn.bb
+++ b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
@@ -7,10 +7,13 @@ LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md
file://Source/WebKit/gtk/webkit/webkit.h;endline=21;md5=b4fbe9f4a944f1d071dba1d2c76b3351 \
file://Source/JavaScriptCore/parser/Parser.h;endline=23;md5=2f3cff0ad0a9c486da5a376928973a90"
-DEPENDS = "zlib enchant gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3"
+# Choice of language backends - icu has issues on Big Endian machines so use pango
+ICU_LIB = "icu"
+ICU_LIB_powerpc = "pango"
+
+DEPENDS = "zlib enchant gnome-keyring libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
+ gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}"
DEPENDS += " ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}"
-DEPENDS_darwin8 = "curl icu libxml2 cairo libxslt libidn gnutls gtk+ gstreamer flex-native gperf-native perl-native-runtime sqlite3"
-DEPENDS_append_qemuppc += "pango"
SRCREV_FORMAT = "source"
@@ -48,10 +51,10 @@ EXTRA_OECONF = "\
UNICODE_CFLAGS=-D_REENTRANT \
"
-#default unicode backend icu breaks in cross-compile when target and host owns different endian type
-EXTRA_OECONF_append_qemuppc += "--with-unicode-backend=glib"
+#default unicode backend icu breaks in cross-compile when target and host are different endian type
+EXTRA_OECONF_append_powerpc += "--with-unicode-backend=glib"
-CPPFLAGS_append_qemuppc += "-I${STAGING_INCDIR}/pango-1.0 \
+CPPFLAGS_append_powerpc += "-I${STAGING_INCDIR}/pango-1.0 \
-I${STAGING_LIBDIR}/glib-2.0/include \
-I${STAGING_INCDIR}/glib-2.0"