aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/sato-icon-theme
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-10-04 12:19:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-04 14:04:03 +0100
commit9d98dbdae4c05fcf50d546f554a04dc3f0bd66c3 (patch)
tree10e75d9f01fe69b40581601188f8bd2728a46baa /meta/recipes-sato/sato-icon-theme
parentae9dbd0e1e26ba2b35cbd08ec731aee62adedc23 (diff)
downloadopenembedded-core-9d98dbdae4c05fcf50d546f554a04dc3f0bd66c3.tar.gz
sato-icon-theme: use gtk-icon-cache helper class
Instead of explicitly updating the icon cache use the helper class that also forces a loader update at the same time. This eliminates the possibility of updating the icon cache without any gdk-pixbuf loaders. Also check that the Sato icon theme isn't already set to avoid appending to the file every time the postinst runs. [YOCTO #2399] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/sato-icon-theme')
-rw-r--r--meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc15
-rw-r--r--meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb2
2 files changed, 8 insertions, 9 deletions
diff --git a/meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc b/meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc
index 9fd10126c1..0bd48143a9 100644
--- a/meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc
+++ b/meta/recipes-sato/sato-icon-theme/sato-icon-theme.inc
@@ -8,18 +8,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=56a830bbe6e4697fe6cbbae01bb7c2b2"
SECTION = "x11"
DEPENDS = ""
-inherit autotools pkgconfig allarch
+inherit autotools pkgconfig allarch gtk-icon-cache
FILES_${PN} += "${datadir}"
EXTRA_OECONF += "--with-iconmap=${STAGING_LIBDIR_NATIVE}/../libexec/icon-name-mapping"
-#explictly setting "Sato" as default icon theme to avoid icon missing due to
-#tricky race condition
+# Explictly setting "Sato" as the default icon theme to avoid flickering from
+# the desktop and settings daemon racing. This shouldn't be done here but in the sato image
pkg_postinst_${PN} () {
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- gtk-update-icon-cache -q /usr/share/icons/Sato
- echo 'gtk-icon-theme-name = "Sato"' >> /etc/gtk-2.0/gtkrc
+ mkdir -p $D/etc/gtk-2.0
+
+ grep -s -q -e ^gtk-icon-theme-name.*\"Sato\" $D/etc/gtk-2.0/gtkrc || \
+ echo 'gtk-icon-theme-name = "Sato"' >> $D/etc/gtk-2.0/gtkrc
}
diff --git a/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
index 108f8e81ae..64053598bc 100644
--- a/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
+++ b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
@@ -2,7 +2,7 @@ require sato-icon-theme.inc
DEPENDS += "icon-naming-utils-native"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://pokylinux.org/releases/sato/${BPN}-${PV}.tar.gz \
file://iconpath-option.patch \