aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/puzzles/puzzles_r9765.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2013-03-04 16:35:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-05 12:29:46 +0000
commitaea07f4010a00d288fab241fd755df4f1063c234 (patch)
treed4046f8c3c12af0790e2b32a40e54b0fc7d8085c /meta/recipes-sato/puzzles/puzzles_r9765.bb
parent81bdf523f01fe9e9e9053e20a687ba7de5041cbf (diff)
downloadopenembedded-core-aea07f4010a00d288fab241fd755df4f1063c234.tar.gz
puzzles: upgrade to 9765
Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/puzzles/puzzles_r9765.bb')
-rw-r--r--meta/recipes-sato/puzzles/puzzles_r9765.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-sato/puzzles/puzzles_r9765.bb b/meta/recipes-sato/puzzles/puzzles_r9765.bb
new file mode 100644
index 0000000000..5ab316169e
--- /dev/null
+++ b/meta/recipes-sato/puzzles/puzzles_r9765.bb
@@ -0,0 +1,62 @@
+DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
+
+DEPENDS = "gtk+ libxt"
+PR = "r0"
+MOD_PV = "${@d.getVar('PV',1)[1:]}"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=31790deb1e1aac4626e7d1bc04587eb0"
+
+# Upstream updates puzzles.tar.gz for the new release, so checksums seem to be changing regularly right now
+SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;rev=${MOD_PV};protocol=svn"
+S = "${WORKDIR}/${BPN}"
+
+#SRC_URI = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.tar.gz"
+#SRC_URI[md5sum] = "9d84769562007e0f99edac77a3b2d27c"
+#SRC_URI[sha256sum] = "b688b5196f8406a23741e973178bdde78e5f8af4d2a88c33ca1ae1cc1a069d15"
+#S = "${WORKDIR}/${BPN}-${PV}"
+
+do_configure () {
+ ./mkfiles.pl
+}
+
+do_compile_prepend = " \
+ export XLDFLAGS='${LDFLAGS} `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --libs`'; \
+ export XLFLAGS=-lm \
+ export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR_NATIVE}/pkg-config gtk+-2.0 --cflags`'; "
+
+FILES_${PN} = "${prefix}/games/* ${datadir}/applications/*"
+FILES_${PN}-dbg += "${prefix}/games/.debug"
+
+do_install () {
+ rm -rf ${D}/*
+ export prefix=${D}
+ export DESTDIR=${D}
+ install -d ${D}/${prefix}/
+ install -d ${D}/${prefix}/games/
+ oe_runmake install
+
+ install -d ${D}/${datadir}/
+ install -d ${D}/${datadir}/applications/
+
+ cd ${D}/${prefix}/games
+ for prog in *; do
+ if [ -x $prog ]; then
+ # Convert prog to Title Case
+ title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
+ echo "making ${D}/${datadir}/applications/$prog.desktop"
+ cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
+[Desktop Entry]
+Name=$title
+Exec=${prefix}/games/$prog
+Icon=applications-games
+Terminal=false
+Type=Application
+Categories=Game;
+StartupNotify=true
+X-MB-SingleInstance=true
+STOP
+ fi
+ done
+}