aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/packagegroups
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-29 11:38:34 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:50 -0700
commit424dcf7046e4ad09dcc664eb1992201195247fcf (patch)
tree26640470c5c7865aec06711fae7009304dc8fea0 /meta/recipes-sato/packagegroups
parentecd818f1a7a46aa0eeffe48445f2cf0db5aab67a (diff)
downloadopenembedded-core-424dcf7046e4ad09dcc664eb1992201195247fcf.tar.gz
Rename task to packagegroup
"Package group" is a much more appropriate name for these than task, since we use the word task to describe units of work executed by BitBake. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/packagegroups')
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb45
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb42
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11.bb68
3 files changed, 155 insertions, 0 deletions
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb
new file mode 100644
index 0000000000..4f3bb47000
--- /dev/null
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-mini.bb
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+DESCRIPTION = "Tasks for core X11 applications"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r1"
+
+PACKAGES = "\
+ packagegroup-core-x11-mini \
+ packagegroup-core-x11-mini-dbg \
+ packagegroup-core-x11-mini-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+
+ALLOW_EMPTY = "1"
+
+ROOTLESS_X = "1"
+
+# xserver-common, x11-common
+VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
+
+# elsa, xserver-nodm-init
+VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
+
+
+RDEPENDS_packagegroup-core-x11-mini = "\
+ dbus \
+ pointercal \
+ matchbox-terminal \
+ matchbox-wm \
+ mini-x-session \
+ ${XSERVER} \
+ ${VIRTUAL-RUNTIME_xserver_common} \
+ ${VIRTUAL-RUNTIME_graphical_init_manager} \
+ liberation-fonts \
+ xauth \
+ xhost \
+ xset \
+ xrandr"
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
new file mode 100644
index 0000000000..380584e223
--- /dev/null
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2007-2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Sato Tasks for Poky"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r32"
+
+PACKAGES = "\
+ packagegroup-core-x11-sato \
+ packagegroup-core-x11-sato-dbg \
+ packagegroup-core-x11-sato-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+NETWORK_MANAGER ?= "connman-gnome"
+NETWORK_MANAGER_libc-uclibc = ""
+
+WEB ?= ""
+#WEB = "web-webkit"
+
+RDEPENDS_packagegroup-core-x11-sato = "\
+ matchbox-desktop \
+ matchbox-session-sato \
+ matchbox-keyboard \
+ matchbox-stroke \
+ matchbox-config-gtk \
+ xcursor-transparent-theme \
+ sato-icon-theme \
+ settings-daemon \
+ gtk-sato-engine \
+ gthumb \
+ x11vnc \
+ libsdl \
+ gaku \
+ ${WEB} \
+ ${NETWORK_MANAGER}"
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
new file mode 100644
index 0000000000..4c16c461a3
--- /dev/null
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11.bb
@@ -0,0 +1,68 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+DESCRIPTION = "Tasks for core X11 applications"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r36"
+
+PACKAGES = "\
+ packagegroup-core-apps-x11-core \
+ packagegroup-core-apps-x11-core-dbg \
+ packagegroup-core-apps-x11-core-dev \
+ packagegroup-core-apps-x11-games \
+ packagegroup-core-apps-x11-games-dbg \
+ packagegroup-core-apps-x11-games-dev \
+ packagegroup-core-x11-base \
+ packagegroup-core-x11-base-dbg \
+ packagegroup-core-x11-base-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+
+ALLOW_EMPTY = "1"
+
+# pcmanfm doesn't work on mips/powerpc
+FILEMANAGER ?= "pcmanfm"
+FILEMANAGER_mips ?= ""
+
+# xserver-common, x11-common
+VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
+
+# elsa, xserver-nodm-init
+VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
+
+
+RDEPENDS_packagegroup-core-x11-base = "\
+ dbus \
+ pointercal \
+ matchbox-wm \
+ matchbox-keyboard \
+ matchbox-keyboard-applet \
+ matchbox-keyboard-im \
+ matchbox-panel-2 \
+ matchbox-desktop \
+ matchbox-session \
+ ${XSERVER} \
+ ${VIRTUAL-RUNTIME_xserver_common} \
+ ${VIRTUAL-RUNTIME_graphical_init_manager} \
+ liberation-fonts \
+ xauth \
+ xhost \
+ xset \
+ xrandr"
+
+
+RDEPENDS_packagegroup-core-apps-x11-core = "\
+ leafpad \
+ ${FILEMANAGER} \
+ matchbox-terminal \
+ sato-screenshot"
+
+
+RDEPENDS_packagegroup-core-apps-x11-games = "\
+ oh-puzzles"