aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-keyboard
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-12-12 11:53:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-13 14:36:24 +0000
commitd49facde4fffc95cd153195fc0114dfbc1bf512c (patch)
tree74305c79e949f4a071fafed982525ce6e8749596 /meta/recipes-sato/matchbox-keyboard
parent3465570601480d2e476e82b8b7254e94f87d2682 (diff)
downloadopenembedded-core-d49facde4fffc95cd153195fc0114dfbc1bf512c.tar.gz
matchbox-keyboard: fix the build with libpng15
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/matchbox-keyboard')
-rw-r--r--meta/recipes-sato/matchbox-keyboard/files/png-fix.patch49
-rw-r--r--meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb5
2 files changed, 52 insertions, 2 deletions
diff --git a/meta/recipes-sato/matchbox-keyboard/files/png-fix.patch b/meta/recipes-sato/matchbox-keyboard/files/png-fix.patch
new file mode 100644
index 0000000000..e3834f5e46
--- /dev/null
+++ b/meta/recipes-sato/matchbox-keyboard/files/png-fix.patch
@@ -0,0 +1,49 @@
+Change matchbox-keyboard to look for "libpng" instead of "libpng12", and fix the
+code so that it works with the 1.2 and 1.5 API.
+
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/configure.ac b/configure.ac
+index 9678cf7..9bbbd76 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -171,24 +171,7 @@ dnl ------ Expat ------------------------------------------------------------
+
+ dnl ------ Check for PNG ---------------------------------------------------
+
+-AC_MSG_CHECKING(for libpng12)
+-
+-if $PKG_CONFIG --exists libpng12; then
+- AC_MSG_RESULT(yes)
+- PNG_LIBS=`$PKG_CONFIG --libs libpng12`
+- PNG_CFLAGS=`$PKG_CONFIG --cflags libpng12`
+-else
+- AC_MSG_RESULT(no)
+- AC_CHECK_LIB([png], [png_create_read_struct],
+- [have_png="yes"], [have_png="no"])
+-
+- if test x$have_png=xyes && test x$have_png_h=xyes; then
+- PNG_LIBS="-lpng -lz"
+- else
+- AC_MSG_ERROR([*** Cannot find libpng12 ****])
+- fi
+-fi
+-
++PKG_CHECK_MODULES(PNG, libpng)
+
+ dnl ------ Debug Build ------------------------------------------------------
+
+diff --git a/src/matchbox-keyboard-image.c b/src/matchbox-keyboard-image.c
+index 8accc3e..6b4b0e8 100644
+--- a/src/matchbox-keyboard-image.c
++++ b/src/matchbox-keyboard-image.c
+@@ -65,7 +65,7 @@ png_file_load (const char *file,
+ return NULL;
+ }
+
+- if ( setjmp( png_ptr->jmpbuf ) ) {
++ if (setjmp (png_jmpbuf (png_ptr))) {
+ png_destroy_read_struct( &png_ptr, &info_ptr, NULL);
+ fclose(fd);
+ return NULL;
diff --git a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
index 430e343b9c..adde25bcf0 100644
--- a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
+++ b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
@@ -12,12 +12,13 @@ RDEPENDS_${PN} = "formfactor dbus-wait"
SECTION = "x11"
SRCREV = "b38f24036cff3be6c2fbcf9ca9881803e69003ac"
PV = "0.0+git${SRCPV}"
-PR = "r3"
+PR = "r4"
SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
file://configure_fix.patch;maxrev=1819 \
file://single-instance.patch \
- file://80matchboxkeyboard.shbg"
+ file://80matchboxkeyboard.shbg \
+ file://png-fix.patch"
S = "${WORKDIR}/git"