aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-keyboard
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-02-14 21:36:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-22 05:52:26 -0800
commit1dfe4f5d49bbbaf1adc28dacac92b5288021309b (patch)
tree918d5b445b25a95a88d4172a5b91654a91226098 /meta/recipes-sato/matchbox-keyboard
parent91a3a48798029ca88a46a528200f4c5252f245e9 (diff)
downloadopenembedded-core-1dfe4f5d49bbbaf1adc28dacac92b5288021309b.tar.gz
matchbox-keyboard: general clean up
Re-order variables, use $PN more, and merge the -dbg packages together. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/matchbox-keyboard')
-rw-r--r--meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
index a7091d2519..6841596f42 100644
--- a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
+++ b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Matchbox virtual keyboard for X11"
HOMEPAGE = "http://matchbox-project.org"
BUGTRACKER = "http://bugzilla.openedhand.com/"
+SECTION = "x11"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
@@ -8,8 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://applet/applet.c;endline=20;md5=e9201b3efa0a81a160b88d6feb5cf75b"
DEPENDS = "libfakekey expat libxft gtk+ matchbox-panel-2"
-RDEPENDS_${PN} = "formfactor dbus-wait"
-SECTION = "x11"
+
SRCREV = "b38f24036cff3be6c2fbcf9ca9881803e69003ac"
PV = "0.0+git${SRCPV}"
PR = "r4"
@@ -26,20 +26,20 @@ inherit autotools pkgconfig gettext gtk-immodules-cache
EXTRA_OECONF = "--disable-cairo --enable-gtk-im --enable-applet"
-PACKAGES += "matchbox-keyboard-im matchbox-keyboard-im-dbg \
- matchbox-keyboard-applet matchbox-keyboard-applet-dbg"
+PACKAGES += "${PN}-im ${PN}-applet"
-FILES_${PN} = "${bindir}/* \
+FILES_${PN} = "${bindir}/ \
${sysconfdir} \
${datadir}/applications \
${datadir}/pixmaps \
${datadir}/matchbox-keyboard"
-FILES_matchbox-keyboard-im = "${libdir}/gtk-2.0/*/immodules/*.so"
-FILES_matchbox-keyboard-im-dbg += "${libdir}/gtk-2.0/*/immodules/.debug"
+FILES_${PN}-dbg += "${libdir}/gtk-2.0/*/immodules/.debug"
+
+FILES_${PN}-im = "${libdir}/gtk-2.0/*/immodules/*.so"
+
+FILES_${PN}-applet = "${libdir}/matchbox-panel/*.so"
-FILES_matchbox-keyboard-applet = "${libdir}/matchbox-panel/*.so"
-FILES_matchbox-keyboard-applet-dbg += "${libdir}/matchbox-panel/.debug"
do_install_append () {
install -d ${D}/${sysconfdir}/X11/Xsession.d/
@@ -50,3 +50,5 @@ do_install_append () {
}
GTKIMMODULES_PACKAGES = "${PN}-im"
+
+RDEPENDS_${PN} = "formfactor dbus-wait"