aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/images
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2012-07-03 12:43:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-03 14:52:15 +0100
commite36d12a9c1cf69540079e48a1dfadbc343758e48 (patch)
tree8506df8a2939fe54ff44b881f60bcf5d9c1ab225 /meta/recipes-sato/images
parent169a89b10817b742c063fcd76721e4dbbcca6199 (diff)
downloadopenembedded-core-e36d12a9c1cf69540079e48a1dfadbc343758e48.tar.gz
image/core-image: Handle conflicting IMAGE_FEATURES.
IMAGE_FEATURES such as 'ssh-server-dropbear' and 'ssh-server-openssh' can't be both enabled. User can use the following variables to define the relationship of image features: IMAGE_FEATURES_REPLACES_foo = "bar" means including image feature "foo" would replace the image feature "bar". IMAGE_FEATURES_CONFLICTS_foo = "bar" means including both image features "foo" and "bar" would cause an parsing error. Signed-off-by: Lianhao Lu <lianhao.lu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/images')
-rw-r--r--meta/recipes-sato/images/core-image-sato-sdk.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb b/meta/recipes-sato/images/core-image-sato-sdk.bb
index 75ed64fd6b..39742efadb 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
@@ -8,6 +8,8 @@ form a standalone SDK."
IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES} dev-pkgs tools-sdk qt4-pkgs"
EXTRA_IMAGE_FEATURES += "tools-debug tools-profile tools-testapps debug-tweaks"
+SSHSERVER_IMAGE_FEATURES = "ssh-server-openssh"
+
LICENSE = "MIT"
inherit core-image