aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-08-04 14:14:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-14 14:07:53 +0100
commit7fc6360dd874c9b6fb9cf785fb2dfe3aec55c9a7 (patch)
treedcf4964f3552c52d7a89784008dfbbd76cbdaea8 /meta/recipes-rt
parentf7533de9228a2927b53cb765d02cbc106632e666 (diff)
downloadopenembedded-core-7fc6360dd874c9b6fb9cf785fb2dfe3aec55c9a7.tar.gz
python3: fix RDEPENDS on several recipes, due to non-existent python3 packages
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Diffstat (limited to 'meta/recipes-rt')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb2
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_1.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
index 012b2dd0a7..60b44a4d25 100644
--- a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
@@ -22,5 +22,5 @@ do_install() {
}
FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
-RDEPENDS_${PN} = "python3 python3-subprocess python3-textutils"
+RDEPENDS_${PN} = "python3 "
RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
diff --git a/meta/recipes-rt/rt-tests/rt-tests_1.1.bb b/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
index 4336c50d63..496f04fdba 100644
--- a/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
+++ b/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
@@ -26,6 +26,6 @@ do_install_ptest() {
cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
}
-RDEPENDS_${PN}-ptest += " stress python3 python3-subprocess python3-multiprocessing python3-datetime python3-re python3-lang python3-misc"
+RDEPENDS_${PN}-ptest += " stress python3 python3-multiprocessing python3-datetime python3-misc"
FILES_${PN} += "${prefix}/src/backfire"