aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_0.84.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-09-11 21:17:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-12 15:10:55 +0100
commitcdf84de3584e17b7fea2401cdb4eaae9752e98a2 (patch)
tree48a69e70cca208053fe7db10e5fe079fdcea4a20 /meta/recipes-rt/rt-tests/rt-tests_0.84.bb
parentf12f75aa57cacc73a0428cedba970076f0abb9f8 (diff)
downloadopenembedded-core-cdf84de3584e17b7fea2401cdb4eaae9752e98a2.tar.gz
rt-tests: Update to 0.84, use the kernel.org git repository
The maintainer of rt-tests has recreated the git repository on kernel.org and has stated that kernel.org is now the official source for rt-tests. Update to 0.84. Remove the user cflags and ldflags patch as it is included in the 0.84 release. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_0.84.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.84.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.84.bb b/meta/recipes-rt/rt-tests/rt-tests_0.84.bb
new file mode 100644
index 0000000000..c54936e13b
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.84.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Real-Time preemption testcases"
+HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
+SECTION = "tests"
+DEPENDS = "linux-libc-headers virtual/libc"
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=ce162fe491d19d2ec67dff6dbc938d50 \
+ file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
+# Version v0.84
+SRCREV = "857cdd5320ce1f293f5dbcbec79cc8fe22b0bebf"
+
+PR = "r0"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/clrkwllms/rt-tests.git"
+
+S = "${WORKDIR}/git"
+
+# need to append rt-tests' default CFLAGS to ours
+CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnulli"
+
+# calling 'uname -m' is broken on crossbuilds
+EXTRA_OEMAKE = "NUMA=0"
+
+do_install() {
+ oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
+ INCLUDEDIR=${includedir}
+}
+
+FILES_${PN} += "${prefix}/src/backfire"