aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-30 09:35:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-30 10:42:07 +0100
commitb8dc9182ed8959ce5a6aa285c3c7f78df2432ac3 (patch)
tree307dfd2369016d1e7f460439a724e83997a029dd /meta/recipes-qt
parent76e8df78bdb641b045e34dcf01d7b9eb626401dc (diff)
downloadopenembedded-core-b8dc9182ed8959ce5a6aa285c3c7f78df2432ac3.tar.gz
qt-4.8.1: Fix compile failures on qemux86
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-qt')
-rw-r--r--meta/recipes-qt/qt4/qt-4.8.1.inc1
-rw-r--r--meta/recipes-qt/qt4/qt-4.8.1/gcc47-fix2.patch50
-rw-r--r--meta/recipes-qt/qt4/qt4-embedded_4.8.1.bb2
-rw-r--r--meta/recipes-qt/qt4/qt4-native_4.8.1.bb2
-rw-r--r--meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.1.bb2
-rw-r--r--meta/recipes-qt/qt4/qt4-x11-free_4.8.1.bb2
6 files changed, 55 insertions, 4 deletions
diff --git a/meta/recipes-qt/qt4/qt-4.8.1.inc b/meta/recipes-qt/qt4/qt-4.8.1.inc
index b42ca0106e..8c38caee3c 100644
--- a/meta/recipes-qt/qt4/qt-4.8.1.inc
+++ b/meta/recipes-qt/qt4/qt-4.8.1.inc
@@ -21,6 +21,7 @@ SRC_URI = "http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${PV}.
file://g++.conf \
file://linux.conf \
file://gcc47-fix.patch \
+ file://gcc47-fix2.patch \
file://disable-fuse-gold-flag.patch \
"
diff --git a/meta/recipes-qt/qt4/qt-4.8.1/gcc47-fix2.patch b/meta/recipes-qt/qt4/qt-4.8.1/gcc47-fix2.patch
new file mode 100644
index 0000000000..09513b6ae7
--- /dev/null
+++ b/meta/recipes-qt/qt4/qt-4.8.1/gcc47-fix2.patch
@@ -0,0 +1,50 @@
+Fixes for gcc 4.7.0, particularly on qemux86
+
+Origin: upstream, http://trac.webkit.org/changeset/93631
+Origin: upstream, http://trac.webkit.org/changeset/113848
+
+Bug: https://bugs.webkit.org/show_bug.cgi?id=62168
+Bug: https://bugs.webkit.org/show_bug.cgi?id=83584
+
+RP 2012/04/30
+
+Upstream-Status: Backport
+
+Index: qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebCore/dom/Element.cpp
+===================================================================
+--- qt-everywhere-opensource-src-4.8.1.orig/src/3rdparty/webkit/Source/WebCore/dom/Element.cpp 2012-04-30 09:15:17.000000000 +0000
++++ qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebCore/dom/Element.cpp 2012-04-30 09:22:04.586008994 +0000
+@@ -1080,7 +1080,7 @@
+ {
+ // Ref currentStyle in case it would otherwise be deleted when setRenderStyle() is called.
+ RefPtr<RenderStyle> currentStyle(renderStyle());
+- bool hasParentStyle = parentNodeForRenderingAndStyle() ? parentNodeForRenderingAndStyle()->renderStyle() : false;
++ bool hasParentStyle = parentNodeForRenderingAndStyle() ? static_cast<bool>(parentNodeForRenderingAndStyle()->renderStyle()) : false;
+ bool hasDirectAdjacentRules = currentStyle && currentStyle->childrenAffectedByDirectAdjacentRules();
+ bool hasIndirectAdjacentRules = currentStyle && currentStyle->childrenAffectedByForwardPositionalRules();
+
+Index: qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebCore/html/HTMLImageElement.cpp
+===================================================================
+--- qt-everywhere-opensource-src-4.8.1.orig/src/3rdparty/webkit/Source/WebCore/html/HTMLImageElement.cpp 2012-03-14 14:01:19.000000000 +0000
++++ qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebCore/html/HTMLImageElement.cpp 2012-04-30 09:22:04.586008994 +0000
+@@ -74,7 +74,7 @@
+ RefPtr<HTMLImageElement> image = adoptRef(new HTMLImageElement(imgTag, document));
+ if (optionalWidth)
+ image->setWidth(*optionalWidth);
+- if (optionalHeight > 0)
++ if (optionalHeight)
+ image->setHeight(*optionalHeight);
+ return image.release();
+ }
+Index: qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebCore/platform/graphics/TiledBackingStoreClient.h
+===================================================================
+--- qt-everywhere-opensource-src-4.8.1.orig/src/3rdparty/webkit/Source/WebCore/platform/graphics/TiledBackingStoreClient.h 2012-03-14 14:01:24.000000000 +0000
++++ qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebCore/platform/graphics/TiledBackingStoreClient.h 2012-04-30 09:22:04.590008963 +0000
+@@ -25,6 +25,7 @@
+ #if ENABLE(TILED_BACKING_STORE)
+ class TiledBackingStoreClient {
+ public:
++ virtual ~TiledBackingStoreClient() { }
+ virtual void tiledBackingStorePaintBegin() = 0;
+ virtual void tiledBackingStorePaint(GraphicsContext*, const IntRect&) = 0;
+ virtual void tiledBackingStorePaintEnd(const Vector<IntRect>& paintedArea) = 0;
diff --git a/meta/recipes-qt/qt4/qt4-embedded_4.8.1.bb b/meta/recipes-qt/qt4/qt4-embedded_4.8.1.bb
index e16264c377..668565e189 100644
--- a/meta/recipes-qt/qt4/qt4-embedded_4.8.1.bb
+++ b/meta/recipes-qt/qt4/qt4-embedded_4.8.1.bb
@@ -1,7 +1,7 @@
require qt-${PV}.inc
require qt4-embedded.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
diff --git a/meta/recipes-qt/qt4/qt4-native_4.8.1.bb b/meta/recipes-qt/qt4/qt4-native_4.8.1.bb
index 533b5d6675..a2a1dbda93 100644
--- a/meta/recipes-qt/qt4/qt4-native_4.8.1.bb
+++ b/meta/recipes-qt/qt4/qt4-native_4.8.1.bb
@@ -1,6 +1,6 @@
require qt4-native.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
# Find the g++.conf/linux.conf in the right directory.
FILESEXTRAPATHS =. "${FILE_DIRNAME}/qt-${PV}:"
diff --git a/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.1.bb b/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.1.bb
index c4bd3cfdc3..e17a8ad808 100644
--- a/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.1.bb
+++ b/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.8.1.bb
@@ -1,6 +1,6 @@
require qt4-tools-nativesdk.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI += "file://qmake_pri_fixes.patch"
diff --git a/meta/recipes-qt/qt4/qt4-x11-free_4.8.1.bb b/meta/recipes-qt/qt4/qt4-x11-free_4.8.1.bb
index 7afb51fea8..6978053692 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free_4.8.1.bb
+++ b/meta/recipes-qt/qt4/qt4-x11-free_4.8.1.bb
@@ -1,7 +1,7 @@
require qt4-x11-free.inc
require qt-${PV}.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
QT_CONFIG_FLAGS_append_armv6 = " -no-neon "