aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-10-06 15:17:14 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-06 15:17:14 +0100
commit5eee854f53e2c1f05d390e96957c2df8e34dea89 (patch)
treeadd615fbbbd11c13a2d7b0a6a81e0f391bc370f3 /meta/recipes-qt/qt4
parent35d095c282aa27bb2c5b90b9ebafeaa4a3de907e (diff)
downloadopenembedded-core-5eee854f53e2c1f05d390e96957c2df8e34dea89.tar.gz
qt4-tools-native: Fix compile failures
fontconfig/freetype are not listed in the dependencies, neither are any of the X components yet this recipe appears to be building the whole UI framework, not just the tools. It turns out this is a dependency for uic3 and qdbus. Since at this time we don't require these, remove them from the build. Its likely cross versions of those specific tools would need to be added due to their dependency on the windowing system compilation. [BUGID #390] Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-qt/qt4')
-rw-r--r--meta/recipes-qt/qt4/qt4-tools-native.inc5
-rw-r--r--meta/recipes-qt/qt4/qt4-tools-native_4.6.3.bb4
2 files changed, 3 insertions, 6 deletions
diff --git a/meta/recipes-qt/qt4/qt4-tools-native.inc b/meta/recipes-qt/qt4/qt4-tools-native.inc
index 7621d629f1..9c78e7cd5e 100644
--- a/meta/recipes-qt/qt4/qt4-tools-native.inc
+++ b/meta/recipes-qt/qt4/qt4-tools-native.inc
@@ -43,11 +43,8 @@ TOBUILD = "\
src/tools/uic \
src/tools/rcc \
src/network \
- src/gui \
- src/tools/uic3 \
tools/linguist/lrelease \
tools/linguist/lupdate \
- tools/qdbus \
"
do_compile() {
@@ -61,7 +58,7 @@ NATIVE_INSTALL_WORKS = "1"
do_install() {
install -d ${D}${bindir}/
install -m 0755 bin/qmake ${D}${bindir}/qmake2
- for i in moc uic uic3 rcc lrelease lupdate qdbuscpp2xml qdbusxml2cpp; do
+ for i in moc uic rcc lrelease lupdate; do
install -m 0755 bin/${i} ${D}${bindir}/${i}4
done
diff --git a/meta/recipes-qt/qt4/qt4-tools-native_4.6.3.bb b/meta/recipes-qt/qt4/qt4-tools-native_4.6.3.bb
index de24b38dea..ac66eb3d5a 100644
--- a/meta/recipes-qt/qt4/qt4-tools-native_4.6.3.bb
+++ b/meta/recipes-qt/qt4/qt4-tools-native_4.6.3.bb
@@ -4,8 +4,8 @@ LICENSE = "LGPLv2.1 | GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24 \
file://LICENSE.GPL3;md5=babc5b6b77441da277f5c06b2e547720 \
file://LGPL_EXCEPTION.txt;md5=411080a56ff917a5a1aa08c98acae354"
-PR = "r0"
+PR = "r2"
-EXTRA_OECONF += " -no-fast -silent -no-rpath"
+EXTRA_OECONF += " -no-fast -silent -no-rpath -no-freetype -no-fontconfig"
TOBUILD := "src/tools/bootstrap ${TOBUILD}"