aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4/qt4-tools-native.inc
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-01-21 16:15:03 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-01 16:14:01 +0000
commitabb87d455d75be6ae05b3124b98a43ccfc90f453 (patch)
tree8b6b8a6b98c40653e3d445be28f2add90baa8d3b /meta/recipes-qt/qt4/qt4-tools-native.inc
parent51b50818922a1be99f50cc1e3386ca914c025427 (diff)
downloadopenembedded-core-abb87d455d75be6ae05b3124b98a43ccfc90f453.tar.gz
qt4-tools-native: update from OpenEmbedded
Differences from OE version: * Add source checksums * Correct LICENCE and move to .inc file * Update HOMEPAGE * Don't specify DEFAULT_PREFERENCE * Remove S and SRC_URI from 4.7.1 (duplicates of .inc file values) * Use http source URL to match other Qt4 recipes * Don't add back tools previously disabled in poky Differences from current (plus the above): * Add Qt 4.7.1 recipe * Specify -embedded to remove dependency on X (as we are only building tools) * Disable some other options to reduce dependencies * Specify -no-freetype / -no-fontconfig in .inc file rather than in .bb * Use INC_PR * Whitespace fixes
Diffstat (limited to 'meta/recipes-qt/qt4/qt4-tools-native.inc')
-rw-r--r--meta/recipes-qt/qt4/qt4-tools-native.inc16
1 files changed, 12 insertions, 4 deletions
diff --git a/meta/recipes-qt/qt4/qt4-tools-native.inc b/meta/recipes-qt/qt4/qt4-tools-native.inc
index 6dca218578..0c4d2c7760 100644
--- a/meta/recipes-qt/qt4/qt4-tools-native.inc
+++ b/meta/recipes-qt/qt4/qt4-tools-native.inc
@@ -1,9 +1,16 @@
DESCRIPTION = "Native tools for Qt/[X11|Mac|Embedded] version 4.x"
-DEPENDS = "zlib-native dbus-native libsm-native"
+DEPENDS = "zlib-native dbus-native"
SECTION = "libs"
HOMEPAGE = "http://qt.nokia.com"
PRIORITY = "optional"
+LICENSE = "LGPLv2.1 | GPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24 \
+ file://LICENSE.GPL3;md5=babc5b6b77441da277f5c06b2e547720 \
+ file://LGPL_EXCEPTION.txt;md5=411080a56ff917a5a1aa08c98acae354"
+
+INC_PR = "r11"
+
inherit native
SRC_URI = "http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
@@ -16,13 +23,14 @@ EXTRA_OECONF = "-prefix ${prefix} \
-L ${STAGING_LIBDIR_NATIVE} \
-I ${STAGING_INCDIR_NATIVE} \
-qt-libjpeg -qt-gif -system-zlib \
- -no-libjpeg -no-libpng \
+ -no-libjpeg -no-libpng -no-libmng -no-libtiff \
-no-accessibility \
-no-cups \
-no-exceptions \
-no-nas-sound \
- -no-nis \
+ -no-nis -no-openssl \
-verbose -release -static \
+ -embedded -no-freetype -no-glib -no-iconv \
-qt3support"
# yank default -e, otherwise we get the following error:
@@ -59,7 +67,7 @@ do_install() {
for i in moc uic rcc lrelease lupdate; do
install -m 0755 bin/${i} ${D}${bindir}/${i}4
done
-
+
install -d ${D}${datadir}/qt4/
cp -PfR mkspecs ${D}${datadir}/qt4/
ln -sf linux-g++ ${D}${datadir}/qt4/mkspecs/${BUILD_OS}-oe-g++