aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4-graphics-system
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-12-27 02:17:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-06 11:27:27 +0000
commitddd3f453e93e460d8db0fcdd04fb4633fe2ebceb (patch)
tree9460b622fa3b0163eab9ea05e17556836fbdc215 /meta/recipes-qt/qt4-graphics-system
parentdca97bbdbfc88c91287e74eb6a3974277f1028b7 (diff)
downloadopenembedded-core-ddd3f453e93e460d8db0fcdd04fb4633fe2ebceb.tar.gz
qt4-graphics-system: add
Allow setting default runtime graphics system engine for Qt4 applications per machine. Depending on the GPU and Xorg driver, this can boost and impact significantly the drawing performance. The default setting is to 'raster' as this offer best performance for most machines GPUs. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta/recipes-qt/qt4-graphics-system')
-rw-r--r--meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
new file mode 100644
index 0000000000..b3aa1e559c
--- /dev/null
+++ b/meta/recipes-qt/qt4-graphics-system/qt4-graphics-system_1.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Set default Qt4 Graphics System to ${QT_GRAPHICS_SYSTEM}"
+SECTION = "x11/base"
+LICENSE = "MIT-X"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+QT_GRAPHICS_SYSTEM ?= "raster"
+
+# xserver-common, x11-common
+VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
+
+def _get_extra_rdepends(d):
+ gs = d.getVar('QT_GRAPHICS_SYSTEM', 1)
+ if gs == "opengl":
+ return "qt4-plugin-graphicssystems-glgraphicssystem"
+
+ return ""
+
+do_install () {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d/
+ cfg_file=${D}/${sysconfdir}/X11/Xsession.d/85xqt-graphicssystem
+ echo "export QT_GRAPHICSSYSTEM=${QT_GRAPHICS_SYSTEM}" > $cfg_file
+ chmod +x $cfg_file
+}
+
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_xserver_common} ${@_get_extra_rdepends(d)}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"