aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/meta
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2011-09-10 11:17:57 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-04 11:34:21 +0100
commit5f6fb92b939147d2d6aa7790a378d4b7cce3ada5 (patch)
treecdc07d2d8101ab5d3ff144116de23011d1ee3dcf /meta/recipes-qt/meta
parentc2f4bae0a100f3752153ecb93adb9ede4f55322a (diff)
downloadopenembedded-core-5f6fb92b939147d2d6aa7790a378d4b7cce3ada5.tar.gz
qt4: fix generated sdk
- qt4-tools-nativesdk : actually the qmake binary which gets installed comes from the native recipe. This patch fix this problem by launching configure twice : once to compile qmake using the right toolchain for nativesdk, and a second time using the native qmake to compile all the other tools for the nativesdk. Then we install the right qmake. - mkspec : the link actually created in qt4-tools-nativesdk's do_install point to nowhere so remove it and generate the link in meta-toolchain-qte as it's the only place where we have all the variable to create it. - toolchain_create_sdk_env_script_append : we need to add OE_QMAKE_CFLAGS, OE_QMAKE_CXXFLAGS and OE_QMAKE_LDFLAGS else the sdk won't find these variables that are inserted by qmake in the Makefiles. - with this patch, oe-core generates a working meta-toolchain-qte which can compile a small example and is properly recognized by qtcreator (this brings oe-core's meta-toolchain-qte to oe-dev's functional state). Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'meta/recipes-qt/meta')
-rw-r--r--meta/recipes-qt/meta/meta-toolchain-qte.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-qt/meta/meta-toolchain-qte.bb b/meta/recipes-qt/meta/meta-toolchain-qte.bb
index 72d58db5e6..735ccd10ab 100644
--- a/meta/recipes-qt/meta/meta-toolchain-qte.bb
+++ b/meta/recipes-qt/meta/meta-toolchain-qte.bb
@@ -10,6 +10,9 @@ QT_DIR_NAME = "qtopia"
QT_TOOLS_PREFIX = "${SDKPATHNATIVE}${bindir_nativesdk}"
toolchain_create_sdk_env_script_append() {
+ echo 'export OE_QMAKE_CFLAGS="$CFLAGS"' >> $script
+ echo 'export OE_QMAKE_CXXFLAGS="$CXXFLAGS"' >> $script
+ echo 'export OE_QMAKE_LDFLAGS="$LDFLAGS"' >> $script
echo 'export OE_QMAKE_CC=${TARGET_PREFIX}gcc' >> $script
echo 'export OE_QMAKE_CXX=${TARGET_PREFIX}g++' >> $script
echo 'export OE_QMAKE_LINK=${TARGET_PREFIX}g++' >> $script
@@ -24,4 +27,8 @@ toolchain_create_sdk_env_script_append() {
echo 'export OE_QMAKE_QDBUSXML2CPP=${QT_TOOLS_PREFIX}/qdbusxml2cpp4' >> $script
echo 'export OE_QMAKE_QT_CONFIG=${SDKTARGETSYSROOT}/${datadir}/${QT_DIR_NAME}/mkspecs/qconfig.pri' >> $script
echo 'export QMAKESPEC=${SDKTARGETSYSROOT}/${datadir}/${QT_DIR_NAME}/mkspecs/linux-g++' >> $script
+
+ # make a symbolic link to mkspecs for compatibility with Nokia's SDK
+ # and QTCreator
+ (cd ${SDK_OUTPUT}/${QT_TOOLS_PREFIX}/..; ln -s ${SDKTARGETSYSROOT}/usr/share/qtopia/mkspecs mkspecs;)
}