aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorRogerio Nunes <ronunes@gmail.com>2013-04-02 20:34:43 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-03 16:54:57 +0100
commite611bba7bba02ba167b2ae3671b00cc99e4fb29c (patch)
treebc1de4a2b11c95e788e12d6e613428dafa402654 /meta/recipes-multimedia
parented07bb4214abb472da6aa7e164a20fd4be127e54 (diff)
downloadopenembedded-core-e611bba7bba02ba167b2ae3671b00cc99e4fb29c.tar.gz
alsa-tools: fix build when x11 and gtk+ not available
Current verion of gtk+ (2.15.24) does not accept pure framebuffer as backend and some alsa-tools sub-modules depend on gtk+. This patch removes those sub-modules from the build only when x11 is not set in DISTRO_FEATURES. Signed-off-by: Rogerio Nunes <ronunes@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools/makefile_no_gtk.patch21
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb8
2 files changed, 27 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools/makefile_no_gtk.patch b/meta/recipes-multimedia/alsa/alsa-tools/makefile_no_gtk.patch
new file mode 100644
index 0000000000..51f934d8f6
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-tools/makefile_no_gtk.patch
@@ -0,0 +1,21 @@
+Remove some sub-components which need gtk+.
+
+Signed-off-by: Rogerio Nunes <ronunes@gmail.com>
+
+Upstream-Status: Inappropriate [configuration]
+
+diff --git a/Makefile b/Makefile
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,8 @@
+ VERSION = 1.0.26.1
+ TOP = .
+-SUBDIRS = ac3dec as10k1 envy24control \
+- mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
+- us428control usx2yloader vxloader echomixer \
++SUBDIRS = ac3dec as10k1 \
++ mixartloader pcxhrloader sb16_csp seq sscape_ctl \
++ us428control usx2yloader vxloader \
+ hwmixvolume hda-verb
+
+ all:
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
index 2b46aaffdd..81ad55acd3 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
@@ -5,14 +5,15 @@ SECTION = "console/utils"
LICENSE = "GPLv2 & LGPLv2+"
DEPENDS = "alsa-lib ncurses"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://ld10k1/COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"
SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/alsa-tools-${PV}.tar.bz2 \
file://mips_has_no_io_h.patch \
- file://autotools.patch"
+ file://autotools.patch \
+ ${@base_contains('DISTRO_FEATURES', 'x11', '', 'file://makefile_no_gtk.patch', d)}"
SRC_URI[md5sum] = "805526ea5d6c40e1f2c94cee86141230"
SRC_URI[sha256sum] = "553338693707fe6ddfc430b9edc4cd2677390e200c9e38de82ede3394e733841"
@@ -21,6 +22,9 @@ inherit autotools
EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}' ACLOCAL_FLAGS='-I ${STAGING_DATADIR}/aclocal'"
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
+PACKAGECONFIG[gtk+] = ",,gtk+,"
+
do_compile_prepend () {
#Automake dir is not correctly detected in cross compilation case
export AUTOMAKE_DIR=${STAGING_DATADIR_NATIVE}/$(ls ${STAGING_DATADIR_NATIVE} | grep automake)