aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-04-01 16:42:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-04 11:47:55 +0100
commitbe37edbdfe1e1ad833155154cabdff16f1d4267f (patch)
tree8e2f8f02403658b3e6d1efdb8c36c03999280cc0 /meta/recipes-multimedia
parent9d502ca8551fd461f869395b1b7e62d6dcf59a84 (diff)
downloadopenembedded-core-be37edbdfe1e1ad833155154cabdff16f1d4267f.tar.gz
alsa-tools: Fix build without x11
The patch had some new tool (hdajackretask) missing which were triggering build failures in O.S. Systems' builder as: ,----[ Build error in a clean tmp, without x11 ] | checking for GTK3... no | configure: error: Package requirements (gtk+-3.0) were not met: | | No package 'gtk+-3.0' found | | Consider adjusting the PKG_CONFIG_PATH environment variable if you | installed software in a non-standard prefix. | | Alternatively, you may set the environment variables GTK3_CFLAGS | and GTK3_LIBS to avoid the need to call pkg-config. | See the pkg-config man page for more details. | make: *** [all] Error 1 `---- Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools/makefile_no_gtk.patch12
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb4
2 files changed, 10 insertions, 6 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools/makefile_no_gtk.patch b/meta/recipes-multimedia/alsa/alsa-tools/makefile_no_gtk.patch
index c6cb5b16ac..26657266a8 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools/makefile_no_gtk.patch
+++ b/meta/recipes-multimedia/alsa/alsa-tools/makefile_no_gtk.patch
@@ -1,21 +1,25 @@
Remove some sub-components which need gtk+.
-Signed-off-by: Rogerio Nunes <ronunes@gmail.com>
-
Upstream-Status: Inappropriate [configuration]
+Signed-off-by: Rogerio Nunes <ronunes@gmail.com>
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+
diff --git a/Makefile b/Makefile
+index 2457a1c..72346d9 100644
--- a/Makefile
+++ b/Makefile
-@@ -1,8 +1,8 @@
+@@ -1,9 +1,9 @@
VERSION = 1.0.27
TOP = .
-SUBDIRS = as10k1 envy24control \
- mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
- us428control usx2yloader vxloader echomixer \
+- hwmixvolume hdajackretask hda-verb
+SUBDIRS = as10k1 \
+ mixartloader pcxhrloader sb16_csp seq sscape_ctl \
+ us428control usx2yloader vxloader \
- hwmixvolume hdajackretask hda-verb
++ hwmixvolume hda-verb
all:
+ @for i in $(SUBDIRS); do \
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb
index 492f8a424f..4f64a387ec 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.27.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.alsa-project.org"
BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php"
SECTION = "console/utils"
LICENSE = "GPLv2 & LGPLv2+"
-DEPENDS = "alsa-lib ncurses ${@base_contains('DISTRO_FEATURES', 'x11', 'gtk+3', '', d)}"
+DEPENDS = "alsa-lib ncurses"
LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://ld10k1/COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"
@@ -21,7 +21,7 @@ inherit autotools-brokensep
EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}'"
PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
-PACKAGECONFIG[gtk+] = ",,gtk+,"
+PACKAGECONFIG[gtk+] = ",,gtk+ gtk+3,"
# configure.ac/.in doesn't exist so force copy
AUTOTOOLS_COPYACLOCAL = "1"