aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-06-24 11:26:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-25 17:43:42 +0100
commit7722fd48995d5d430d58b94ecf69a6ad9f1c741b (patch)
tree2e6ad011375dfdd8abfcb5ad04fad6d821e2024b /meta/recipes-multimedia
parentd40606de85a42c48327dead5d6e4c9a1de2cc39c (diff)
downloadopenembedded-core-7722fd48995d5d430d58b94ecf69a6ad9f1c741b.tar.gz
gst-plugins-bad: element selection rationalisation
Using --with-plugins means you only get the elements you enable, so we were dropping vast numbers of useful plugins such as the MPEG muxers. Instead, follow gst-plugins-base by using PACKAGECONFIG to enable/disable plugins with optional dependencies. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb18
1 files changed, 12 insertions, 6 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb b/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb
index 87f338ffbc..a3a120463d 100644
--- a/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb
@@ -6,18 +6,24 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
file://gst/tta/crc32.h;beginline=12;endline=29;md5=71a904d99ce7ae0c1cf129891b98145c"
-DEPENDS += "gst-plugins-base curl"
+DEPENDS += "gst-plugins-base"
PR = "r4"
inherit gettext
-EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl --disable-cdaudio --disable-directfb \
- --with-plugins=wavpack,mpegvideoparse --disable-vdpau --disable-apexsink \
- --disable-orc --disable-neon"
+EXTRA_OECONF += "--disable-experimental \
+ --disable-sdl --disable-cdaudio --disable-directfb \
+ --disable-vdpau --disable-apexsink"
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'librsvg', '', d)}"
-PACKAGECONFIG[librsvg] = "--enable-rsvg,--disable-rsvg,librsvg,"
+PACKAGECONFIG ??= "bzip curl \
+ ${@base_contains('DISTRO_FEATURES', 'x11', 'rsvg', '', d)}"
+
+PACKAGECONFIG[bzip] = "--enable-bz2,--disable-bz2,bzip2"
+PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
+PACKAGECONFIG[rsvg] = "--enable-rsvg,--disable-rsvg,librsvg,"
+PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc"
+PACKAGECONFIG[neon] = "--enable-neon,--disable-neon,neon"
ARM_INSTRUCTION_SET = "arm"