summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-08-17 11:27:32 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-18 17:00:16 +0100
commit03ccc234386f753e1b0129ec557e67bcd04cc69e (patch)
tree76bfcd97d9baa9a2f689a77d36f7ca4c9d26f906 /meta/recipes-kernel
parent5debc9bc25110b836b76927c61b2455e5e235a84 (diff)
downloadopenembedded-core-03ccc234386f753e1b0129ec557e67bcd04cc69e.tar.gz
kernel-devsrc: fix 5.14+ objtool compilation
In v5.14+, x86 requires not just elfutils, but the elf headers on the target to build objtool (required for 'scripts parepare'), so we tweak our RDEPENDS to ensure that the right headers are on the target. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 23de1a4917..d39573965f 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -322,7 +322,7 @@ RDEPENDS:${PN} = "bc python3 flex bison ${TCLIBC}-utils"
# 4.15+ needs these next two RDEPENDS
RDEPENDS:${PN} += "openssl-dev util-linux"
# and x86 needs a bit more for 4.15+
-RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils', '', d)}"
+RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-dev', '', d)}"
# 5.8+ needs gcc-plugins libmpc-dev
RDEPENDS:${PN} += "gcc-plugins libmpc-dev"
# 5.13+ needs awk for arm64