aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-03-02 16:36:39 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-02 22:05:02 +0000
commitd2fb7fff291b83700d487be093223c1533d915ce (patch)
tree21254ff90b895208b211ea734db1183bc1caa8a5 /meta/recipes-kernel
parent4dc9bde20602c7565979c7ebdea1a36c7ab3f458 (diff)
downloadopenembedded-core-d2fb7fff291b83700d487be093223c1533d915ce.tar.gz
kernel-yocto: inhibit BSP description warnings for custom linux-yocto kernels
We don't require that a yocto custom kernel + defconfig have a full BSP description (but of course it would be better if they did). Since this isn't a requirement, we shouldn't alarm users by generating a BSP description warning. To implement this, we add a bsp audit level flag (like the one that exists for kconfig audits), and only set it to activate in the versioned linux-yocto recipes. [YOCTO: #7370] Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb1
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb1
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb1
-rw-r--r--meta/recipes-kernel/linux/linux-yocto.inc1
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.14.bb1
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.19.bb1
6 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
index 8e2189654b..bd61c4a927 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
@@ -14,6 +14,7 @@ LINUX_VERSION ?= "3.14.29"
PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
index db9ad738c3..d110297246 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
@@ -7,6 +7,7 @@ require recipes-kernel/linux/linux-yocto.inc
LINUX_VERSION ?= "3.14.29"
KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "f65678ef48c5d41af914d2769e4dd01411c1df96"
SRCREV_meta ?= "6eddbf47875ef48ddc5864957a7b63363100782b"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb
index 1997e30a25..d10449aab3 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb
@@ -7,6 +7,7 @@ require recipes-kernel/linux/linux-yocto.inc
LINUX_VERSION ?= "3.19"
KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "43b9eced9ba8a57add36af07736344dcc383f711"
SRCREV_meta ?= "f7a81274b461d0c748964d75c24bea8574d350fb"
diff --git a/meta/recipes-kernel/linux/linux-yocto.inc b/meta/recipes-kernel/linux/linux-yocto.inc
index 79b3f256f4..c62f8ca97d 100644
--- a/meta/recipes-kernel/linux/linux-yocto.inc
+++ b/meta/recipes-kernel/linux/linux-yocto.inc
@@ -28,6 +28,7 @@ SRCREV_FORMAT ?= "meta_machine"
# 1: report options that are specified, but not in the final config
# 2: report options that are not hardware related, but set by a BSP
KCONF_AUDIT_LEVEL ?= "1"
+KCONF_BSP_AUDIT_LEVEL ?= "0"
LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.14.bb b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
index ac01430897..9cdd3eea0d 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
@@ -28,6 +28,7 @@ LINUX_VERSION ?= "3.14.29"
PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.19.bb b/meta/recipes-kernel/linux/linux-yocto_3.19.bb
index f856d19f93..f1bf3bea90 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.19.bb
@@ -28,6 +28,7 @@ LINUX_VERSION ?= "3.19"
PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"