aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-03-11 09:14:54 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-20 11:03:17 +0000
commit6f39aae20d88a2d764c3a85617cd36b81af804f1 (patch)
treece2161a11800b3a646d77cf8117f71e8f7931413 /meta/recipes-kernel
parent1e60b5216a89a34eba7749244eeb53d5d12864eb (diff)
downloadopenembedded-core-6f39aae20d88a2d764c3a85617cd36b81af804f1.tar.gz
perf: add bash to RDEPENDS
perf has a dependency on bash in its utilities, which generate the following warning: WARNING: QA Issue: perf requires /bin/bash, but no providers in its RDEPENDS [file-rdeps] Since perf is not installed on extremely small systems, we just add bash to the RDEPENDS, rather than modifying scripts or removing content. [YOCTO: #7445] Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index f69d177949..420fe6b57a 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -170,7 +170,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
-RDEPENDS_${PN} += "elfutils"
+RDEPENDS_${PN} += "elfutils bash"
RDEPENDS_${PN}-archive =+ "bash"
RDEPENDS_${PN}-python =+ "bash python"
RDEPENDS_${PN}-perl =+ "bash perl perl-modules"