aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-07-26 16:45:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-15 14:18:39 +0100
commit443473a88dd94a5fe0d6bc7a5d14d45ea5bbdec5 (patch)
tree7f329f25d8bf8c732f88ab6369e8456aa4f95da8 /meta/recipes-kernel
parent5f8f9ff0413683d1a1f01fceaa709def723aca91 (diff)
downloadopenembedded-core-443473a88dd94a5fe0d6bc7a5d14d45ea5bbdec5.tar.gz
powertop: cleanup update-alternatives deprecated code
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/powertop/powertop_1.13.bb13
1 files changed, 6 insertions, 7 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_1.13.bb b/meta/recipes-kernel/powertop/powertop_1.13.bb
index b4f45ddbbc..db54ed0f59 100644
--- a/meta/recipes-kernel/powertop/powertop_1.13.bb
+++ b/meta/recipes-kernel/powertop/powertop_1.13.bb
@@ -11,7 +11,7 @@ DEPENDS = "virtual/libintl ncurses"
# powertop 1.13 needs lspci
RDEPENDS_${PN} = "pciutils"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
file://stub_out_the_ncurses_calls_in_dump_mode.patch \
@@ -25,12 +25,6 @@ EXTRA_OEMAKE = "VERSION=\"${PV}\" EXTRA_LIBS=${EXTRA_LIBS}"
EXTRA_LIBS_libc-uclibc = "-lintl"
-inherit update-alternatives
-ALTERNATIVE_NAME = "powertop"
-ALTERNATIVE_PATH = "${bindir}/powertop"
-ALTERNATIVE_LINK = "${base_bindir}/powertop"
-ALTERNATIVE_PRIORITY = "100"
-
do_configure() {
# We do not build ncurses with wide char support
sed -i -e 's:lncursesw:lncurses ${EXTRA_LIBS}:g' ${S}/Makefile
@@ -40,3 +34,8 @@ do_install() {
oe_runmake install DESTDIR=${D}
}
+inherit update-alternatives
+ALTERNATIVE_${PN} = "powertop"
+ALTERNATIVE_TARGET[powertop] = "${bindir}/powertop"
+ALTERNATIVE_LINK_NAME[powertop] = "${base_bindir}/powertop"
+ALTERNATIVE_PRIORITY = "100"