aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2010-12-07 20:06:29 -0800
committerSaul Wold <sgw@linux.intel.com>2010-12-09 08:18:17 -0800
commit3d08b9f2c65835822b1c0ed30e3170f02f877ce3 (patch)
tree774991d51470129319c18bb6b32c9b0c2d5a2b7c /meta/recipes-kernel
parentba5e0b9531b9a967aa3d408a13024590d96b8391 (diff)
downloadopenembedded-core-3d08b9f2c65835822b1c0ed30e3170f02f877ce3.tar.gz
SRC_URI Checksums Additionals
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/kexec/kexec-tools_2.0.2.bb3
-rw-r--r--meta/recipes-kernel/latencytop/latencytop_0.5.bb3
-rw-r--r--meta/recipes-kernel/lttng/lttng-control_0.88.bb3
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_0.8.bb3
-rw-r--r--meta/recipes-kernel/lttng/lttng-viewer_0.12.35.bb3
-rw-r--r--meta/recipes-kernel/module-init-tools/module-init-tools_3.12.bb3
-rw-r--r--meta/recipes-kernel/modutils/modutils_2.4.27.bb3
-rw-r--r--meta/recipes-kernel/oprofile/oprofile_0.9.6.bb3
-rw-r--r--meta/recipes-kernel/powertop/powertop_1.13.bb3
9 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kexec/kexec-tools_2.0.2.bb b/meta/recipes-kernel/kexec/kexec-tools_2.0.2.bb
index 758d3ec9fd..0d15b5b862 100644
--- a/meta/recipes-kernel/kexec/kexec-tools_2.0.2.bb
+++ b/meta/recipes-kernel/kexec/kexec-tools_2.0.2.bb
@@ -3,3 +3,6 @@ export LDFLAGS = "-L${STAGING_LIBDIR}"
EXTRA_OECONF = " --with-zlib=yes"
PR = "r0"
+
+SRC_URI[md5sum] = "bc401cf3262b25ff7c9a51fc76c8ab91"
+SRC_URI[sha256sum] = "549ab65c18a2229b6bf21b6875ca6bbe0e579bca08c3543ce6aaf8287a0b4188"
diff --git a/meta/recipes-kernel/latencytop/latencytop_0.5.bb b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
index 75c72c1072..247ec168ab 100644
--- a/meta/recipes-kernel/latencytop/latencytop_0.5.bb
+++ b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
@@ -12,6 +12,9 @@ PR = "r1"
SRC_URI = "http://www.latencytop.org/download/latencytop-${PV}.tar.gz \
file://latencytop-makefile.patch"
+SRC_URI[md5sum] = "73bb3371c6ee0b0e68e25289027e865c"
+SRC_URI[sha256sum] = "9e7f72fbea7bd918e71212a1eabaad8488d2c602205d2e3c95d62cd57e9203ef"
+
CFLAGS += "${LDFLAGS}"
do_install() {
diff --git a/meta/recipes-kernel/lttng/lttng-control_0.88.bb b/meta/recipes-kernel/lttng/lttng-control_0.88.bb
index a96b80c813..502064f186 100644
--- a/meta/recipes-kernel/lttng/lttng-control_0.88.bb
+++ b/meta/recipes-kernel/lttng/lttng-control_0.88.bb
@@ -10,6 +10,9 @@ LTTDATE = "09242010"
SRC_URI = "http://ltt.polymtl.ca/files/lttng/ltt-control-${PV}-${LTTDATE}.tar.gz"
+SRC_URI[md5sum] = "ca81d874352756837518d74c9d1091a7"
+SRC_URI[sha256sum] = "89c625a4d1b0823954217df232a31f3cae31de7b6655c0d885a61bece0dfcd88"
+
S = "${WORKDIR}/ltt-control-${PV}-${LTTDATE}"
inherit autotools
diff --git a/meta/recipes-kernel/lttng/lttng-ust_0.8.bb b/meta/recipes-kernel/lttng/lttng-ust_0.8.bb
index 79b620e981..7d88b1638d 100644
--- a/meta/recipes-kernel/lttng/lttng-ust_0.8.bb
+++ b/meta/recipes-kernel/lttng/lttng-ust_0.8.bb
@@ -16,6 +16,9 @@ PR = "r0"
SRC_URI = "http://lttng.org/files/ust/releases/ust-${PV}.tar.gz"
+SRC_URI[md5sum] = "333ff7c8fef92b31dff85789865bb791"
+SRC_URI[sha256sum] = "802398bc2c3ad5c80bd236d1ee24968f4da8a1401695e8dc15cb396ac836abb4"
+
S = "${WORKDIR}/ust-${PV}"
inherit autotools
diff --git a/meta/recipes-kernel/lttng/lttng-viewer_0.12.35.bb b/meta/recipes-kernel/lttng/lttng-viewer_0.12.35.bb
index 71bcb8082f..550d8f5184 100644
--- a/meta/recipes-kernel/lttng/lttng-viewer_0.12.35.bb
+++ b/meta/recipes-kernel/lttng/lttng-viewer_0.12.35.bb
@@ -16,6 +16,9 @@ SECTION = "devel"
ALTNAME = "lttv-${PV}-20082010"
SRC_URI = "http://lttng.org/files/packages/${ALTNAME}.tar.gz"
+
+SRC_URI[md5sum] = "ebcbc4e21184b4b0dcb0611b4977dad8"
+SRC_URI[sha256sum] = "d258b13cd76c37e4f8395c06159986dd45517bef312895ffa59722087a2879e7"
S = "${WORKDIR}/${ALTNAME}"
inherit autotools
diff --git a/meta/recipes-kernel/module-init-tools/module-init-tools_3.12.bb b/meta/recipes-kernel/module-init-tools/module-init-tools_3.12.bb
index 6c312b4cec..3d7c287092 100644
--- a/meta/recipes-kernel/module-init-tools/module-init-tools_3.12.bb
+++ b/meta/recipes-kernel/module-init-tools/module-init-tools_3.12.bb
@@ -37,3 +37,6 @@ pkg_postinst_module-init-tools-depmod() {
pkg_prerm_module-init-tools-depmod() {
update-alternatives --remove depmod /sbin/depmod.26
}
+
+SRC_URI[md5sum] = "8b2257ce9abef74c4a44d825d23140f3"
+SRC_URI[sha256sum] = "d012ab07ea26721467a85a775f34747c1c8897e37f16bec5317d8a72ef8b4f17"
diff --git a/meta/recipes-kernel/modutils/modutils_2.4.27.bb b/meta/recipes-kernel/modutils/modutils_2.4.27.bb
index 497d1f18ff..0174f83973 100644
--- a/meta/recipes-kernel/modutils/modutils_2.4.27.bb
+++ b/meta/recipes-kernel/modutils/modutils_2.4.27.bb
@@ -14,6 +14,9 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/modutils/v2.4/modutils-${P
file://armeb.patch;patch=1 \
file://gcc4.patch;patch=1"
+SRC_URI[md5sum] = "bac989c74ed10f3bf86177fc5b4b89b6"
+SRC_URI[sha256sum] = "ab4c9191645f9ffb455ae7c014d8c45339c13a1d0f6914817cfbf30a0bc56bf0"
+
inherit autotools
# modutils go in /sbin
diff --git a/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb b/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb
index 9679411bec..894bb9a931 100644
--- a/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb
+++ b/meta/recipes-kernel/oprofile/oprofile_0.9.6.bb
@@ -19,6 +19,9 @@ PR = "r0"
SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
file://opstart.patch \
file://acinclude.m4"
+
+SRC_URI[md5sum] = "4e407093ac06200185d5a5e6437d7242"
+SRC_URI[sha256sum] = "3f0dd40a7749fc650d25d79d42ebbff8f3b6db310c36e7c3839696cc09077880"
S = "${WORKDIR}/oprofile-${PV}"
inherit autotools
diff --git a/meta/recipes-kernel/powertop/powertop_1.13.bb b/meta/recipes-kernel/powertop/powertop_1.13.bb
index da3f034a0e..39884063d6 100644
--- a/meta/recipes-kernel/powertop/powertop_1.13.bb
+++ b/meta/recipes-kernel/powertop/powertop_1.13.bb
@@ -15,6 +15,9 @@ PR = "r0"
SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
file://stub_out_the_ncurses_calls_in_dump_mode.patch"
+SRC_URI[md5sum] = "78aa17c8f55178004223bf236654298e"
+SRC_URI[sha256sum] = "2bc866089496877dd26d2d316ad5763ab8ecb5e28aefba44bc5d355dcdc58d98"
+
CFLAGS += "${LDFLAGS}"
EXTRA_OEMAKE = "VERSION=\"${PV}\""