aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-07-02 11:14:40 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-05 15:26:21 +0100
commit9436f568c23fa669f6db9c75c6e7d0a9f92f5a3a (patch)
treeebf859a9dbdead75c8ecb6b670e6160c19250d8f /meta/recipes-kernel
parentb11db8fbb68188a00b10ba9c25a22426db642bde (diff)
downloadopenembedded-core-9436f568c23fa669f6db9c75c6e7d0a9f92f5a3a.tar.gz
lttng-modules: Update to 2.2.0 based release
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch66
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.2.0.bb (renamed from meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb)5
2 files changed, 55 insertions, 16 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch b/meta/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
index aa24171f31..30f825c414 100644
--- a/meta/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
+++ b/meta/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
@@ -7,35 +7,75 @@ build and install lttng-modules, we do this replacement for
it as-is.
Signed-off-by: Zumeng Chen <zumeng.chen@windriver.com>
----
- Makefile | 7 +++----
- 1 files changed, 3 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
-index 5ac13d7..25caad5 100644
+index a9d1cb1..c1b65b9 100644
--- a/Makefile
+++ b/Makefile
-@@ -38,17 +38,16 @@ obj-m += lib/
+@@ -43,19 +43,19 @@ obj-m += lib/
+ endif # CONFIG_TRACEPOINTS
+
+ else # KERNELRELEASE
+- KERNELDIR ?= /lib/modules/$(shell uname -r)/build
++ KERNEL_SRC ?= /lib/modules/$(shell uname -r)/build
+ PWD := $(shell pwd)
+ CFLAGS = $(EXTCFLAGS)
+
+ default:
+- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
++ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
+
+ modules_install:
+- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
++ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install
+
+ clean:
+- $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
++ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
+
+ %.i: %.c
+- $(MAKE) -C $(KERNELDIR) M=$(PWD) $@
++ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) $@
+ endif # KERNELRELEASE
+diff --git a/README b/README
+index 8c5dd46..6bd3334 100644
+--- a/README
++++ b/README
+@@ -27,8 +27,8 @@ access to your full kernel source tree), and use:
+ If you need to specify the target directory to the kernel you want to build
+ against, use:
+
+-% KERNELDIR=path_to_kernel_dir make
+-# KERNELDIR=path_to_kernel_dir make modules_install
++% KERNEL_SRC=path_to_kernel_dir make
++# KERNEL_SRC=path_to_kernel_dir make modules_install
+ # depmod -a kernel_version
+
+ Use lttng-tools to control the tracer. LTTng tools should automatically load
+diff --git a/probes/Makefile b/probes/Makefile
+index 225803c..3449866 100644
+--- a/probes/Makefile
++++ b/probes/Makefile
+@@ -212,18 +212,18 @@ endif
endif
-
+
else
- KERNELDIR ?= /lib/modules/$(shell uname -r)/build
++ KERNEL_SRC ?= /lib/modules/$(shell uname -r)/build
PWD := $(shell pwd)
CFLAGS = $(EXTCFLAGS)
-
+
default:
- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
-
+
modules_install:
- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install
-
+ /sbin/depmod -a
+
clean:
- $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
-
+
endif
---
-1.7.5.4
-
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb b/meta/recipes-kernel/lttng/lttng-modules_2.2.0.bb
index 0bbaa817ca..dd35396205 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.2.0.bb
@@ -10,9 +10,8 @@ DEPENDS = "virtual/kernel"
inherit module
-SRCREV = "b374c356eb4827b68754d68adc0f1c94b5de9faa"
-PV = "2.1.1"
-PR = "r0"
+SRCREV = "1b26381c19dd2d9fa41f52d8dc13b15b8dd32c7c"
+PV = "2.2.0"
SRC_URI = "git://git.lttng.org/lttng-modules.git;protocol=git \
file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"