aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-03-31 13:56:29 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-31 22:57:34 +0100
commit92776093766d4b0bb2613214274fa28dc59b6126 (patch)
tree424aa0da26a01b78b0d43056097153d33a5f608e /meta/recipes-kernel
parent6a83546e374b674a58a6d161d655c7e31a3b6da4 (diff)
downloadopenembedded-core-92776093766d4b0bb2613214274fa28dc59b6126.tar.gz
linux-yocto/3.14: introduce versioned recipes
The release kernel for Yocto 1.6 is the 3.14 kernel, so we introduce the versioned recipes here. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb21
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.14.bb37
2 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
new file mode 100644
index 0000000000..2e142bfd90
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
@@ -0,0 +1,21 @@
+require recipes-kernel/linux/linux-yocto.inc
+
+KBRANCH = "standard/tiny/base"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+LINUX_VERSION ?= "3.14"
+
+KMETA = "meta"
+
+SRCREV_machine ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
+SRCREV_meta ?= "fc8c30398dbc3cdea787a1042242d4aab689d0ae"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES = ""
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.14.bb b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
new file mode 100644
index 0000000000..d5202cd439
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
@@ -0,0 +1,37 @@
+require recipes-kernel/linux/linux-yocto.inc
+
+KBRANCH = "standard/base"
+
+# board specific branches
+KBRANCH_qemuarm = "standard/arm-versatile-926ejs"
+KBRANCH_qemumips = "standard/mti-malta32"
+KBRANCH_qemuppc = "standard/qemuppc"
+KBRANCH_qemux86 = "standard/common-pc/base"
+KBRANCH_qemux86-64 = "standard/common-pc-64/base"
+KBRANCH_qemumips64 = "standard/mti-malta64"
+
+SRCREV_machine_qemuarm ?= "c966987f88a0ee5753c3dee87e7a962d0cad5376"
+SRCREV_machine_qemumips ?= "61811c215c601ee96ccbf79333bbc73482b0f017"
+SRCREV_machine_qemuppc ?= "0d5cf5e938f4e6d3c6a398e98c8ece3ce05539f7"
+SRCREV_machine_qemux86 ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
+SRCREV_machine_qemux86-64 ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
+SRCREV_machine_qemumips64 ?= "ccb2a788551a7951563ac44a27175c6f28501008"
+SRCREV_machine ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
+SRCREV_meta ?= "fc8c30398dbc3cdea787a1042242d4aab689d0ae"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
+
+LINUX_VERSION ?= "3.14"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+KMETA = "meta"
+
+COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
+
+# Functionality flags
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
+KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"