aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-12 00:10:11 -0400
committerSaul Wold <sgw@linux.intel.com>2014-05-23 09:09:38 -0700
commit6d2dcba210ac60ec709eb6956c34474a021ab425 (patch)
treee9499537025ee0ca259ca7303adeec9763258a09 /meta/recipes-kernel
parentef5892a2cd8eb85ba8de47a970122a8a6d5724ad (diff)
downloadopenembedded-core-6d2dcba210ac60ec709eb6956c34474a021ab425.tar.gz
linux-yocto/3.14: aufs, edgerouter config and -rt
Updating the 3.14 SRCREVs to import the following changes: - enable AUFS: a missing Kbuild patch was preventing aufs from compiling - edgerouter: remove RTC configuration options - preempt-rt recipe. The patch for 3.14 is availble, so we populate the recipe. (From OE-Core rev: 8e38a24a9d9cd44733a25d3de307907a788d643d) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb27
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.14.bb16
3 files changed, 37 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
new file mode 100644
index 0000000000..330eda4f1f
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
@@ -0,0 +1,27 @@
+require recipes-kernel/linux/linux-yocto.inc
+
+KBRANCH = "standard/preempt-rt/base"
+KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
+
+SRCREV_machine ?= "b5ed38affb23ff64a0382ee0dd116ffe74c4a379"
+SRCREV_machine_qemuppc ?= "79cb133d2d1b0b816cc1cd888f4ed4ef81570793"
+SRCREV_meta ?= "09424cee646626c04105f08455a58fabb27eff31"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+LINUX_VERSION ?= "3.14"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+KMETA = "meta"
+
+LINUX_KERNEL_TYPE = "preempt-rt"
+
+COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuppc|qemumips)"
+
+# Functionality flags
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
+KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
index a441a53fb9..c4cd331ab7 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
@@ -8,8 +8,8 @@ LINUX_VERSION ?= "3.14"
KMETA = "meta"
-SRCREV_machine ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
-SRCREV_meta ?= "928d7b2ddad0abc8827055c51ba34225878344a0"
+SRCREV_machine ?= "144595ef6215a0febfb8ee7d0c9e4eb2eaf93d61"
+SRCREV_meta ?= "09424cee646626c04105f08455a58fabb27eff31"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.14.bb b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
index 7f0ec2b559..2c2cace0dd 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
@@ -10,14 +10,14 @@ KBRANCH_qemux86 = "standard/common-pc/base"
KBRANCH_qemux86-64 = "standard/common-pc-64/base"
KBRANCH_qemumips64 = "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "c966987f88a0ee5753c3dee87e7a962d0cad5376"
-SRCREV_machine_qemumips ?= "61811c215c601ee96ccbf79333bbc73482b0f017"
-SRCREV_machine_qemuppc ?= "0d5cf5e938f4e6d3c6a398e98c8ece3ce05539f7"
-SRCREV_machine_qemux86 ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
-SRCREV_machine_qemux86-64 ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
-SRCREV_machine_qemumips64 ?= "ccb2a788551a7951563ac44a27175c6f28501008"
-SRCREV_machine ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
-SRCREV_meta ?= "928d7b2ddad0abc8827055c51ba34225878344a0"
+SRCREV_machine_qemuarm ?= "d7a5330e50f78f63789b91cb9880b38633d33450"
+SRCREV_machine_qemumips ?= "38f344fcab8c0ee29f40edb92dd6612eff4579bf"
+SRCREV_machine_qemuppc ?= "b28241db34ab66f9e86718d8c94276d65d2457bb"
+SRCREV_machine_qemux86 ?= "f9048769cc178f2f64ed492a9a649827167d9a34"
+SRCREV_machine_qemux86-64 ?= "144595ef6215a0febfb8ee7d0c9e4eb2eaf93d61"
+SRCREV_machine_qemumips64 ?= "c4e08d47c5eb36ae056f2eab82a74c3638e72e06"
+SRCREV_machine ?= "144595ef6215a0febfb8ee7d0c9e4eb2eaf93d61"
+SRCREV_meta ?= "09424cee646626c04105f08455a58fabb27eff31"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"