aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-06-25 16:17:10 -0400
committerSaul Wold <sgw@linux.intel.com>2013-06-27 09:49:14 -0700
commit3bd592e832c6ce10947882f37564c12f4fa7f8e2 (patch)
treed5d2bb0da283f52dcafaa8f688f3cdac8a6051eb /meta/recipes-kernel
parent31ab19ab69bc6504df01cac7ee0670ca78d247ab (diff)
downloadopenembedded-core-3bd592e832c6ce10947882f37564c12f4fa7f8e2.tar.gz
linux-yocto/3.4: allow kernel feature _appends to be overriden
Updating the linux-yocto 3.4 recipe's feature flags to match the 3.8 recipe, which has the following change: It was pointed out that the current way the KERNEL_FEATURES variable is appended in the base linux-yocto recipe doesn't allow the appended features to be prevented in a layer without using python code and a recipe finalize hook. To allow easier overriding of 'extra' or 'optional' features that are defined in the linux-yocto recipe, we create a KERNEL_EXTRA_FEATURES variable. This variable can be set in a layer to define extra features or cleared to prevent the recipe's extra features from being appended to the core functionality. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index 9d6d8c7976..ade96be5e4 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -23,7 +23,8 @@ KMETA = "meta"
COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
# Functionality flags
-KERNEL_FEATURES_append = " features/netfilter/netfilter.scc"
-KERNEL_FEATURES_append_qemux86=" cfg/sound.scc"
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"