aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-03-04 16:46:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-07 14:55:26 +0000
commit01f640f2e878ef86db4138f422fdf74f5f41c8c5 (patch)
treee776badfc291916d3e84a29e65b612ae0a4754d0 /meta/recipes-kernel
parent90c3a0401c566e26d89a5c0410b2a51fe27b95b2 (diff)
downloadopenembedded-core-01f640f2e878ef86db4138f422fdf74f5f41c8c5.tar.gz
perf: don't use oe.path.relative
Instead of using oe.path.relative, use the Python Standard Library function os.path.relpath. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 6258cbbe09..56576d5d65 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -86,10 +86,10 @@ EXTRA_OEMAKE += "\
'sysconfdir=${sysconfdir}' \
'perfexecdir=${libexecdir}/perf-core' \
\
- 'ETC_PERFCONFIG=${@oe.path.relative(prefix, sysconfdir)}' \
- 'sharedir=${@oe.path.relative(prefix, datadir)}' \
- 'mandir=${@oe.path.relative(prefix, mandir)}' \
- 'infodir=${@oe.path.relative(prefix, infodir)}' \
+ 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
+ 'sharedir=${@os.path.relpath(datadir, prefix)}' \
+ 'mandir=${@os.path.relpath(mandir, prefix)}' \
+ 'infodir=${@os.path.relpath(infodir, prefix)}' \
"
# PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h